ActiveReports 15 .NET Edition
ActiveReports 15 User Guide / Welcome to ActiveReports 15 / Product Requirements
In This Topic
    Product Requirements
    In This Topic

    To install and use ActiveReports 15, you need the following hardware and software. 

    Hardware requirements (minimum)

    Development Environments

    .NET Framework .NET Core 3.1 or .NET 5
    Application Windows Forms, WPF, ASP.NET Web Forms, ASP.NET MVC5, JavaScript libraries (JSViewer, Web Designer)  Windows Forms, WPF, ASP.NET Core MVC, JavaScript libraries (JSViewer, Web Designer)
    Operating System Windows 8.1, or 10, or
    Windows Server 2012, 2012 R2, 2016, and 2019
    Windows 8.1, or 10, or
    Windows Server 2012, 2012 R2, 2016, and 2019
    Microsoft Visual Studio 2015, 2017, and 2019 2019 (16.4+)
    2019 (16.8+) for .NET 5
    Internet Information Services 8.0, 8.5, 10 8.0, 8.5, 10

    Note: The Express Editions of Visual Studio do not work with ActiveReports, as they do not support packages.

    You are required to perform following updates from the links provided for proper working in Visual Studio.

    Developer Pack for .NET Framework 4.6.2 or above

    https://www.microsoft.com/download/visual-studio-sdks

    NuGet Package

    Visual Studio Update Packages

    TypeScript Plugin

    Download latest TypeScript plugin (required for Angular applications)

    Run Time Supported Environments

    Windows Forms and WPF

    Web Development

    .NET Framework .NET Core 3.1 or .NET 5
    Server
    Version

    Microsoft® .NET Framework Version 4.6.2 and above

    Microsoft® .NET Core 3.1 or .NET 5

    Application ASP.NET Web Forms, ASP.NET MVC5, JavaScript libraries (JSViewer, Web Designer)  ASP.NET Core MVC, JavaScript libraries (JSViewer, Web Designer)
    Operating System

    Windows 8.1, or 10, or
    Windows Server 2012, 2012 R2, 2016, and 2019

    Windows 8.1, or 10, or
    Windows Server 2012, 2012 R2, 2016, and 2019
    macOS 10.13+, RHEL 6+, Fedora 29+, Ubuntu 16.04+, Debian  9+, SLES 12 SP2+

    Internet Information Services 8.0, 8.5, 10 -
    Client
    Browser

    Microsoft Internet Explorer 11
    Microsoft Edge
    Google Chrome (v50 or higher)
    Firefox (v57 and above)
    Safari (macOS 10 and higher)
    Safari (iOS 10 and higher)
    Safari (iPadOS 13 and higher)


    Limitations of .NET Core support:

    Notes for Section Reports support on Linux environment:

    For running and exporting applications with Section reports on Linux environment, you need to install 'libgdiplus'. Such operations are not supported in Linux based Azure Web applications.

    See Also