As we develop our roadmap, we need to periodically review the current technology stack. We’re planning to make .NET framework 4.5.2 the minimum supported version across all our ComponentOne Studio Enterprise products. In addition, we plan to upgrade the C# version of all control assemblies to 7.0.

Before we move forward with these changes, we need your feedback. Your work plays an important role in how we'll make this transition.

Take the 2-minute .NET framework survey

Reasons for the shift to 4.5.2 as minimum:

  • Microsoft has stopped support for .NET Framework 4.5.1 and below. This means there will be no security patches.
  • Moving to .NET 4.5+ makes the controls compatible with NET Standard.
  • New features in later frameworks will help us to develop the products faster.
  • It will be easier for us to maintain the code base.

What this means for you:

  • No support for Windows XP
  • MVC 3 and 4 versions will not be supported
  • You'll need Visual Studio 2017 to build any source code that we provide due to the C# version upgrade. However, you'll still be able to use the compiled versions of the controls in older VS.

Once we announce this change, we'll provide adequate time for upgrade before expiring older frameworks.

Please fill out this simple, 2-minute survey to help us implement this decision.