3D surface not displaying all data

Originally Posted 9 October 2013, 5:27 pm EST

  • Originally Posted 9 October 2013, 5:27 pm EST

    I am using Olectra Chart 6 3D ActiveX control and want to display a surface plot. But the first Y column with data is not displayed. I thought about upgrading to Chart 8 and installed an evaluation version of Studio for ActiveX 2013 v3. Unfortunately, it has the same behavior. What can I do to display the data for in this case the wind speed of 8 m/s?
    I have attached the oc3 file in question.

    regards,
    Wolfgang
    2013/10/Chart8.zip
  • Reply

    Hello Wolfgang,

    Please attach a sample application in which we can reproduce the error.

    Thanks,
    Richa
  • Reply

    Hello Richa,

    there is no application necessary. Just load the Chart8.oc3 into a Chart8 3D control. This file is included in Chart8.zip file which I attached to my first post.
    If you look at the value table (ChartGroup -> Data -> Edit Data) you can see that most of the chart group values are holes but for the columns Y8 to Y12 there are real values. However, on the zoned surface the values of the column Y8 are displayed as if they were also hole values.

    Regards
    Wolfgang
  • Reply

    Hello Wolfgang,

    Apologies for delay in response.

    I tested this with a sample .oc3 file and I could not observe the issue. I am attaching the oc3 file and the sample used for testing. Could you please modify this as per your application and send me the updated sample.

    Thanks,
    Richa
    2013/11/test.zip

    2013/11/ShowOC3.zip
  • Reply

    Hello Richas,

    Unfortunately, I do not have Visual Studio 6 installed, so I cannot deal with visual basic projects. I am using Microsoft's "TstCon" application to test ActiveX controls.
    Did you try the oc3 file included in "Chart8.zip" which was attached to my first post?
    The result should be as shown in the attached "OC3-Display.jpg" and you can see the data in the attached "OC3-Data.jpg".

    Regards
    Wolfgang



  • Reply

    Hello Wolfgang,

    I am not able to understand the query clearly. As per my understanding, you wish to draw the surface from the y-axis. If this is so, please set the Min value to 9 ( Axes-> Y -> Scale -> Min). Refer to the attached image for the output.

    If my understanding is incorrect, please let me know.

    Thanks,
    Richa

  • Reply

    Hello Richas,

    Yes, I can set the min value to 9. But how can I display the data of Y8? If I set the Y axis min value to 8 I would expect the data of Y8 are displayed. Instead, hole values seems to be displayed. Actually I think these are interpolated values between Y7 and Y8 where Y7 are all hole values (1E+308).
    In my opinion this is not correct.

    Regards
    Wolfgang
  • Reply

    Hello Wolfgang,

    The plotting of chart is dependant on the data and the Y8 data is plotted correctly. Please refer to the attached oc3 file, wherein only y8 is used. Let me know if this makes sense.

    Thanks,
    Richa
    2013/11/Chart8_updated.zip
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels