Blank pages in generated pdf when using 64bit version of vsprint8.ocx and vspdf8

Originally Posted 18 June 2015, 5:21 am EST

  • Originally Posted 18 June 2015, 5:21 am EST

    When we generate a report from our application with the 32bit version of the ActivX controls, we will always get a correct rendered PDF. When we compile and run the program as a 64bit application, the generated report contains blank pages in most cases. Furthermore some of the blank pages may have a wrong size. We have also tried it with the newest version 8.0.20132.171 of the controls but we got the same result.
    Do you have any ideas what is going wrong there?

    The document is rendered correctly on screen for both versions of the program/controls.
    2015/06/BucketCylinderHydraulics_x86.pdf

    2015/06/BucketCylinderHydraulics_x64.pdf
  • Reply

    Hi Thomas,

    I could not replicate the issue in a simple project at my end. The PDF file for the VSPrinter is saved using the ConvertDocument method of VSPdf correctly. Please find the project and the Pdf file used for testing attached.

    You are requested to modify the attached application or share a small stripped down application so that we can replicate the issue at our end and assist you further accordingly. In addition to this, please share the environment details (OS and architecture) as well.

    You may also want to take a look at the following post where a similar issue has been discussed:
    http://our.componentone.com/groups/topic/pdf-file-generated-using-vspdf-ocx-when-save-as-saved-to-blank-pages-adobe-reader-xi/

    Thanks and Regards,
    Pragati Kaushik
    2015/06/MultiRowHdr_SavePDF.zip
  • Reply

    I can add that we experience the same - often a given report results in a blank page with wrong size. When the PDF is opened the zoom level is set to 6400%.

    If we generate the same report again it sometimes is correct, but most of the time it results in blank pages.

  • Marked as Answer

    Reply

    Hi,

    Thanks for sharing the details.
    However, it would be difficult for me to comment on the cause of the problem without replicating it at my end. Could you please share a stripped down application so that I can try reproducing the problem at my end and assist you further at the earliest?

    Also, share the environment details (OS and architecture) where the problem occurs at your end.

    Thanks and Regards,
    Pragati Kaushik
  • Reply

    It is not possible to supply you with an example of our application - It is created in Progress (A 4gl runtime).

    I have tried to make a C# test app that could reproduce the error, but it seems like there are some problems with vsview8/vspdf8 when run as x64 on windows server 12 R2 - I get message saying the app has stopped working.

    The same app works fine on windows 7 - It also works fine if I compile with target anyCPU with option prefer 32-bit.

    2015/08/testapp.zip
  • Reply

    Hi,

    As per the development team, it should not be set to x64 since running 'Any CPU' on a 64bit machine defaults to 64bit runtime, which cannot load, run or find in the registry the 32 bit DLLs of the project.

    However I tried running the application with target AnyCPU with option prefer 32-bit and could not replicate the blank pages related problem. All the 100 Pdf files were generated correctly. Please find them attached.

    Thanks and Regards,
    Pragati Kaushik
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels