Getting Class not registered while opening PropertyPage (vsflex8l.ocx) - WIN7 64-bit OS

Originally Posted 17 October 2012, 10:09 am EST

  • Originally Posted 17 October 2012, 10:09 am EST

    Noticed a similar case/topic...anyway...

    Customer environment is:

    - Windows 7 Enterprise SP1, 64-bits OS
    - Visual Basic 6 Enterprise, 32-bits
    - Componet One Studio Active X (C1StudioActiveX_2011v1)

    Installed successfully C1 software and activated the license.

    Opening an empty VB6 project and add the flexgrid object via "Project/Components" (vsflex8l.ocx) works fine.
    Also able to drag the object from toolbox onto the form.
    When I right-click on object and selects "Propteries", I got the following error message:

    “Class not registered. Looking for object with CLSID:{808A9BF8-DFA8-4A0A-BB85-F6F989EE8FDC}” error.

    The vsflex8l.ocx file is found and referenced in SysWOW64 catalogue.

    I have tried to unregister and register the component vsflex8l.ocx with regsvr32 under SysWOW64 (with Run as admin) several times. It says it was registered successfully, but still I have this problem.

    Note that I have "Elevated Privileges" in this OS environment.

    I also tried to search for CLSID in registry (using regedit), but could not find the CLSID.

    Any idea what I'm doing wrong here?

    Best regards,
    Arild Nordhagen
  • Reply


    I would suggest you to look for the C:WindowsSystem32VSPpg8.dll in the System32 dir and then register it

    1) Start>run>regsvr32 VSPpg8.dll

    If its Win 7 64 bit then

    1) Open command prompt as Admin
    2) Goto SysWow64
    3) regsvr32 VSPpg8.dll (Make sure this is present in the dir)

  • Reply

    Thanks for feedback!

    1. VSPpg8.dll exists in SysWow64
    2. I run regsvr32 VSPpg8.dll with was registered successfully
    3. I know see CLSID:{808A9BF8-DFA8-4A0A-BB85-F6F989EE8FDC}” referenced in registry

    However, I still receive the same error message (class not registered)...strange.

    Any other files that needs to be registered?

    Best regards,
    Arild Nordhagen.
  • Reply

    Interesting observation....
    I tried to install the same package on the Windows XP SP3 session.

    Same problem here -> Same "Class not registered" error message.
    When I tried to register the VSPpg8.dll file in XP (regsvr32 "C:windowssystem32VSPpg8.dll"), I got the following error message:

    "C:windowssystem32VSPpg8.dll is not an executable file and no registration helper is registered for this file type".

    Arild N.
  • Reply

    Note that the package we downloaded is named (2011 v.1).

    Arild N.
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels