problem with true dbgrid and true db dropdown

Originally Posted 29 April 2014, 8:47 am EST

  • Originally Posted 29 April 2014, 8:47 am EST

    Hello,

    i try to use true dbgrid in combination with true dbdropdown on a property page. every time a click on the register whee both controls are on i get an assertion error. In the output window i can read the following error:
    InitNew or Load on OLE control {4CF51E4D-CAF8-4C34-97C0-C4725784CF95} failed.
    >>> Result code: 0x800a017c

    The error code means ctl_e_invalid_property. what i know is that the error occurs during the creation of the true dbdropdown control. but i don't know where to debug this problem because the control is created automatically via the framework. and I also don't know which property might be invalid. can anybody give me a hint? I am using visual studio 2010 on Windows 7 64 bit. My programm is an mfc app. my tdbg8.ocx is V8.0.20121.365

    thanks a lot,
    Georg
  • Reply

    Hello Georg,

    The Error usually refers to the incorrect registration of the controls on your machine.
    Try registering the controls on your machine again.

    Also, please check the case with the latest TrueDBGrid Build : 8.0.20133.372 available at :
    http://prerelease.componentone.com/activex/C1TrueDBGrid/2013-T3/

    and check the case in a new application.

    Kindly refer to the attached MFC sample wherein I could not observe any such issues while creating the TrueDBGrid and TrueDBDropDown controls in the designer.

    Let us know your observations on the same.

    Regards,
    Reema
    2014/05/testapp.zip
  • Reply

    I tried the newest version of tdbg8 by copying the contents of the archive to my system, overwrote the already existing files and registered the ocx with regsvr32 c:\windows\syswow64\tdbg8.ocx. I created a test application but the error still exists. I attatch the file and hope you are able to reproduce the error.

    thanks alot,
    Georg
    2014/05/testdbgrid.zip
  • Reply

    Hello Georg,

    Please refer to the attached video demonstrating the behaviour with the latest TrueDBGrid Build : 8.0.20133.372 on my Windows 7 64 bit machine.

    I could not observe the mentioned error in the Output window and the project could be build and run successfully.

    As mentioned earlier, try registering the controls again on your machine.
    Please refer to the following blog post discussing the same :
    http://our.componentone.com/2012/02/10/registration-of-64-bit-activex-controls/

    Or, you can just download the ComponentOne Studio for ActiveX installer from the following link and install the same on your machine. It will register the controls correctly on your machine :
    http://www.componentone.com/SuperProducts/StudioActiveX/

    Let me know if I missed something here.

    Regards,
    Reema
    2014/05/truedbdropdownIssue.gif
  • Reply

    hello,

    i installed the 2014v1- Package (both 32bit and 64bit controls). i have got an local admin account only for my machine inmy company. The installation worked fine and the error remained. then i tried to register tbg8.ocx with c1regsvr and got no error. But my problem still exists. Is there a way to verify the correctness of the registration of the control? Or is it possible that our antivir software blocks the correct registration? we only use Microsofts defender on our systems. I attached a file created with Sysinternalssuite's procmon where i recorded the time when the problem happened so you might be able to gather information from it.
    2014/05/test.csv
  • Reply

    Hello Georg,

    I understand your concerns but we are still unable to reproduce the issue at our end.

    Possible reasons for the errors could be :
    1. The incorrect registration of the control on your machine.
    2. Registering via local account.
    3. The Visual Studio ToolBox is not getting updated and the application is not reffering to the correct locations of the registered ocx(s).

    Please follow the below mentioned steps which might help :
    1. If registering the ActiveX controls manually then perform it with full administrative rights.
    - If installing the ActiveX setup on your machine, then grant the permission to all the users.
    2. Kinsly check for in the SysWow64 folder of your machine, if the correct ocx(s) have been registered or not ? Or, if there exist some other older references of the same control, then remove them.
    3. While creating the application, browse to the respective location of the ocx in the SysWow64 folder and then add the control in the ToolBox and then on the form.
    - Compile and run the application.

    Also, please refer to the following link, it might be helpful :
    http://support.microsoft.com/kb/140346

    Kindly share your observations on the above.

    If the issue still persists, then you are requested to share a video demonstrating the following :
    1. How exactly are you registering the control on your machine ?
    2. Are you registering the control using administrative rights ?
    3. Exactly when the error is generated while creating a new application ?

    This would be useful in providing you with further appropriate assistance.

    Regards,
    Reema
  • Marked as Answer

    Reply

    Hello,

    thanks for your patience. now it works. I removed the grid and the dropdown controls from the from and placed them new again. it seemed to be a problem in the resource script.

    Thanks again for your help and have a nice weekend,
    Georg
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels