VsFlexGrid8 display stops getting refreshed

Originally Posted 24 August 2017, 4:11 pm EST

  • Originally Posted 24 August 2017, 4:11 pm EST

    Hi,
    We're encountering a strange behaviour at one of our customers. I'd appreciate to know if people experienced this and how they solved it.
    We're using VsFlexGrid 8.0.20163.309 (vsFlex8.dll) embedded in OpenEdge 10.2B08 windows.
    Sometimes, after an unknow event (user manipulation, leak of some kind, both, ...) one of the vsflexgrid stops being refreshed. This results in a grey, black or white display area. Sometimes the previously displayed data stays instead of the last computed ones. Our Windows can contain more than 10 instances of the OCX, and only one is concerned at a time. It's not always the same.
    It can occur after 15mn of usage, sometimes even less. It looks to me like if the redraw property of the component was set to false. I've tried to force this property to true (even if it says it is already). But it doesn't change the behaviour.
    Sometimes, juste maximizing the OCX frame and setting it back to its original size restores the display. Sometimes, we must close the window (the process stays in memory).
    GDI objects don't seem to leak (below 1000 objects for the process). Unless there's a spike too fast to be viewed.

    Thanks for any idea !

    Best regards,
  • Reply

    Hi Frederic,

    I have not encountered such an issue before. Though I am not sure about OpenEdge, can you please share specific code which demonstrates the problem at your end?

    ~Pragati
  • Reply

    Hi Pragati and thanks for your reply.
    Our main problem with this issue is that we are still unable to reproduce it, despite our efforts. Only the end users encounter it.
    So right now I am unable to get a limited demo code. They should send us some videos of the problem soon, I hope I can determine the action leading to it.

    Regards

  • Marked as Answer

    Reply

    Hi Frederic,

    I understand that. But its difficult for me to comment on the cause of the problem without actually replicating the same at my end. Please see if you can share the stripped down code/project.

    ~Pragati
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels