I must choose a date for the last date parameter, otherwise the report cannot run.

Posted by: htian on 3 August 2017, 3:20 pm EST

  • Posted 3 August 2017, 3:20 pm EST

    Hi, I found if I add 2 date parameters to a report, the report cannot run by click the 'view report' button. I must change the date value for the second date parameter even though it already has value. Seems the displayed date was not set to the second parameter but the first parameter.

    I attached a example.

    Thanks,
    Tian Hu (Howard)

    2012/05/TestDateParam.rdlx
  • Replied 3 August 2017, 3:20 pm EST

    Hello,

    I created a report with two date parameters and provided the default values for both the parameters and the report is working fine when I click on the Preview button in the designer. I have attached the sample report and data along with the post. Kindly have a look at the attached report using the sample data provided. I would request you to modify the attached report to depict your issue so that I can replicate the issue at my end and debug it further.

    Thanks,
    Manpreet Kaur

    2012/05/TestReport and Data.zip
  • Replied 3 August 2017, 3:20 pm EST

    Hi, I just removed the default value for the second date parameter of your sample to reproduce the issue. I attached the modified sample file.
    The issue is if I do not add default value to the second date parameter, then the report can not be run by click the 'view report' button in the report viewer.

    Thanks,
    Tian Hu (Howard)

    2012/05/TestDateParam1_removeDefaultValue.rdlx
  • Replied 3 August 2017, 3:20 pm EST

    Hello,

    I was able to replicate the issue at my end and it seems to be a bug. I have entered case number 162079 for the same. As a workaround I would suggest you to set the AllowNull property of the second parameter to True, to generate the report on the first click without having to change the value of the second parameter.

    Thanks,
    Manpreet Kaur
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels