Active reports 1.0 on 64 bit machines

Posted by: captaind51 on 4 August 2017, 3:20 pm EST

  • Posted 4 August 2017, 3:20 pm EST

    I have a small program created in VB6 with Active Reports 1.0 actrpt.dll version

    When users with the 64 bit computers and windows version 7 go to print a report they get "Runtime Error 48" Error running dll

    We 've tried unregistering the dll and then re-registering it, no luck. My guess is the way Windows 7 handles the 32 bit registry via redirection.

    Does anyone know of a fix?
  • Replied 4 August 2017, 3:20 pm EST


    I would suggest you to kindly check this forum post which tells about using ActiveReports for VB6 on a 64 bit machine. You will notice that Microsoft does not support the Visual Basic 6 IDE under a 64 bit machine.

  • Replied 4 August 2017, 3:20 pm EST


    I've aready came across similar responses.

    Thought you might of had a fix.

    I'll keep looking.


  • Replied 4 August 2017, 3:20 pm EST


    ActiveReports 1.0 happens to be a very old version of the product. However, I have not been able to experience similar issues at my end when I print reports generated out of the same in a 64-bit machine. Please make sure that you have placed the ActiveReports dlls in the C;\Windows\SysWow64 folder of your machine.Also, can you check how is the behavior when you try printing a normal VB6 form from a VB6 application in this machine.

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels