Automation Error -2147352567

Posted by: hiskid on 4 August 2017, 2:39 pm EST

  • Posted 4 August 2017, 2:39 pm EST

    I am working on a report that is hanging because the sub-report crashes. The report crashes on the line below:

    Me.Export objARExport

    I have several other reports that are built the same way, for this client that work fine. I built these reports from a template, so they are both the same except for the SQL and fields.

    When I run this report locally, it works fine (using a copy of the customers database), but when I run it on the production system it hangs.

    The actrpt.dll and rptexpt.dll are identical on my local and production systems.

    My client is becoming impatient and I am running out of idea's.

    Can anyone help me?

    TIA!

    John
  • Replied 4 August 2017, 2:39 pm EST

    I had the same problem. It turned out that it does not like the file path, although it was a perfectly valid path, which exists on the server.
  • Replied 4 August 2017, 2:39 pm EST

    Thanks for the info.  This appears to fit the discription of the issue, as a server usually has much tighter security.  Therefore, while a directory exists, if the proper permissions don't exist for the account running that process, it will be the same as referring to a path that doesn't exist, or isn't able to be created.
  • Replied 4 August 2017, 2:39 pm EST

    That is exactly it. But the error returned should be more descriptive than 'Automation error Exception occurred '. This is misleading and as your first suggestion was something to do with the version of the components etc. It will be nice in some of the next version if we see this error handled more appropriately.

  • Replied 4 August 2017, 2:39 pm EST

    Try the following lines in your reportend event:
     Dim pdf As New ActiveReportsPDFExport.ARExportPDF
     pdf.Export Me.Pages

    What build are you using?  If you are using at least 1.1.0.85, you can also try the attached PDF export from the latest build of AR2.

    2005/07/pdfexpt.zip
  • Replied 4 August 2017, 2:39 pm EST

    Hi,


    I have a similar problem.


    Here is the situation.


    My reports application generates PDF & Excel version of the a report (two seperate designers). For one particular report it is generating the PDF but while generating excel it throws the following error.


    Run time error: -2147352567


    Automation Error exception occurred.


    The interesting point here is the excel report is getting generated when i point it to development database (oracle) and when I point the same code to either test or production it throws the above error.


    Why is it giving the error only on this particular excel report? and Why is it giving this error on test and production databases only?


    Please throw some light on this issue.


    Thanks in advance.

  • Replied 4 August 2017, 2:39 pm EST

    I would recommend checking all of the paths in your project, since this is only occurring on your test or production server.  There may be a difference in the file paths on the different servers.  Also, please check all file and database permissions on the test and production servers, as this may be preventing your data from being accessed correctly.
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels