Data Export causes Application Crash

Posted by: ultimate245 on 4 August 2017, 2:49 pm EST

  • Posted 4 August 2017, 2:49 pm EST

    Hi Guys,


    I have a problem with the data export functionality where it is causing my application to crash.


    I have had this problem ever since the first builds of Active Reports 2.0 and it has never been fixed in any updates. I am wondering what I have done wrong, because as far as I can tell by searching the forums no-one has ever reported it as a problem.


    I use various export filters, inclding PDF, text, richtext and excel. On some computers this causes my application to completely crash with a GPF, even though I have error handling etc.


    I am fairly sure that it is not an issue with the code that I am using for the export, which in some cases is pretty much an exact copy of the sample code provided. The problem also happens when using the COPY button on the standard built-in viewer. In some cases the user clicks the copy button, and when they paste the information into MS-Word, my application quits. As I understand it the the COPY button need and uses the RichText filter DLL. Other cases I get and Automation Error The callee  is not available and disappeared; all connections are invalid.he callee is not available and disappeared; all connections are invalid.


    This does not happen on all PC's, and does not happen on any PC's in the my office. However, it does happen on a very significant number of my clients PC's. I am not sure of the exact percentage, as I only hear from the ones where is does not work, but I would have around 25 clients where I know it does not work. Most clients do not use the export functionality and I am not sure of how many clients use this successfully, but I guess that it is around the same or less than the ones where it does not work.


    The problem is not confined to any one operating system, I have had the problem on 98, 2000 and XP. I have checked and double checked the files that I am redistributing. All the required files are there as specified in the documentation, and they are the same version as what the application is being built with.


    Just wondering if anyone has experienced this problem or similar.


     


    Thanks


     

  • Replied 4 August 2017, 2:49 pm EST

    Since 1997 I have had similar problem.


    My cases:


    1.  The network printer on Win95/98 and report's mashine on WinNT/2000/XP.


    2. Virtual memory with specific printer.


    3. FontSize 8.75 with specific font and specific regional settings.


     4. Specific exports dll version.


    5. The MyExportInstance.Export rpt.Pages works better than rpt.Export MyExportInstance.


    6. Windows security.


    You may send to DD a small run-able mashine with your problem.


     

  • Replied 4 August 2017, 2:49 pm EST

     It seems that a very significant number of your clients PC's have AR1 exports in the registry


    or you use AR1 exports references for compiling and your clients PC's have AR2 exports in the registry.


    Exports - pdfexpt.dll,exclexpt.dll,...

  • Replied 4 August 2017, 2:49 pm EST

    This is a very good thought. My PC has got AR1 on it as my AR2 is an upgrade version which requires AR1.I know that I don't specifically reference the old versions, but there might be something in the registry causing the problem.


    Also it is possible some clients are using an old installer package wich may install AR1 dlls intially, before an upgrade replaces and registers the latest AR2 DLL's.


    Thanks for the lead, I will investigate further.

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels