Error 5000: Error in processing report.

Posted by: ricwha on 4 August 2017, 3:11 pm EST

  • Posted 4 August 2017, 3:11 pm EST

    We have a custom report that we assisted one of our customers in developing. For 1 1/2 years it has worked without incident and has not been modified—aside from updates to the base AR2 dlls all of which worked unto just recently. They report that a few weeks ago this report and a couple of others have stopped working for all of their users.



    The error message that is now being produced is:



    Error 5000: Error in processing report.

    [Extended Info: CP internal=103002



    I have run this report internally against a lot of our test databases and cannot produce this or any other error. Their database has only 132 records so size should not be an issue. The obvious cause seems to something has changed in their environment, but as is customary I am told nothing new has been installed.



    I have attached the rpx files. I have looked at the posts but I don’t know how they apply here. No one else is reporting this, so far, outside the one location. What or where can we even begin to look in determining what is happening.



    This is based on version 2.5.0.1309




    2008/07/AltieReportforWHOLEDATABASE.zip
  • Replied 4 August 2017, 3:11 pm EST

    Hello ,


    In most cases the problem relates to the database connection,


    also, there are few cases when problem appeared because of corrupted font and antivirus software.


    I recommend you to create for tests the VB project which will display a same data without report, e.g. via DataGrid.


    Thanks,


    Sergey Romanov.

  • Replied 4 August 2017, 3:11 pm EST

    Database connection covers a lot of ground. Can you be more specific? This report runs for a while then fails. Other reports using the same fonts work.



    They are running the same virus software I am and its not an issue here. Data seems to be ok, too. So maybe it is a connection issue, but in what way might this be happening that AR can't report it more specifically.

    .
  • Replied 4 August 2017, 3:11 pm EST

    Possibly, the data control can't read some datarow or field.


    Try to add the logging in FethData event and find what datarow provides the exception.


    Thanks,


    Sergey Romanov.

  • Replied 4 August 2017, 3:11 pm EST

    Well we sort of isolated the issue. It was in the Notes sub-report and appears to be something that AR cannot handle—I suspect the RTF control. Every other approach we used on the record worked and other Rich Text components worked. There was no issue outside of the AR rendering although we noted the report before it stopped slew out about 16 blank pages. Sometimes it went to the next record and failed.



    By deleting the record and all it’s children the report worked. This was certainly not a virus issue; I don’t see how it relates to a connection issue either. AR consistently failed on the same record while all our other comports rendered the total content accurately and without an issue.



    Due to the confidential nature of the data I couldn’t get the database. If I had access to it I might have tried a few other things but nothing revealed anything wrong with the data. It was only about 7kb long and had no unusual formatting that we could detect that didn’t appear in other data segments which AR rendered correctly.

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels