Error Number: 5000 Error in processing report [Extended Info: CP internal=103002]

Posted by: vivekrai23 on 4 August 2017, 3:21 pm EST

  • Posted 4 August 2017, 3:21 pm EST

    WE are getting this error on one of our client machine.

    They are getting this error only one system and rest of the system its working ,we dont know the exact problem.

    We are using Active Report 2.0 (ver. 2.4.1.1283). It is a Windows Form (Visual Basic 6.0) application. OS is Windows 2003 Server R2.
  • Replied 4 August 2017, 3:21 pm EST

    We have tried with all options like disabling antivirus ,installing microsoft scripts 5.7 ,putting logging in the active_reports evets.

    No clue still can any one help with this.
  • Replied 4 August 2017, 3:21 pm EST

    Vivek,

    Also check if there are some restrictions while accessing the database to which the report connects from this client's machine

    Regards,
    Prantik
  • Replied 4 August 2017, 3:21 pm EST

    No we are not having a problem with the Database also after executing the line object.report.run false

    Its getting into the active reports events flow.

    And in that after the ReportHeader_format event the error occurs which is not traceable from our code as it directly goes into the events Activereport_error and error is thrown by our application.

    Can you please tell where might be the problem now if its not with the DB.
  • Replied 4 August 2017, 3:21 pm EST

    Hello Vivek,

    Can you please attach the RPX of the report and let me check if there might be anything specific in the ReportHeader section that might cause this? Further, if there is extensive code (not script) within the report, please send the DSR and DSX files of the report for me to check further. If you are uncomfortable in sharing the code in a public forum, you may send the same with an email to powersupport@grapecity.com

    Regards,
    Prantik
  • Replied 4 August 2017, 3:21 pm EST

    I've already sent all the files to the powersupport@grapecity.com on 19th March to Jon .Can you please check and let me know since i'm not able to get this error for asimple utility using activereports that i've designed.

    I can't send you the project to this as our code contains many dependencies .

  • Replied 4 August 2017, 3:21 pm EST

    By the way what type of restrictions while accessing the database are to talking about .
  • Replied 4 August 2017, 3:21 pm EST

    By the way what type of restrictions while accessing the database are you to talking about .
  • Replied 4 August 2017, 3:21 pm EST

    Vivek,

    I was refering to access permissions to the database. Is it possible that the windows account under which the report is run does not have permissions to access the database. To narrow down the problem, could you try putting some logging mechanism inside the events of the report. This would help to figure out when is the error exactly triggered. Further, could you also try adding the following line of code to the reportstart event of the report and see if this gives you results.

    me.Printer.DeviceName=""

    Regards,
    Prantik
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels