Get error 5000 if more than 1 line in the detail section

Posted by: jonathanjones on 4 August 2017, 2:47 pm EST

  • Posted 4 August 2017, 2:47 pm EST

    We are getting a strange error with one of our customers. If they print
    a report (done as a sort of letter layout) it will work fine if there
    is only 1 line in the detail section. If there would be 2 or more lines
    in the detail section they get an error 5000 CP internal = 103002.



    We have tried everything, The exact same report layout and same data
    tested on one of our PC's works fine so its not directly related to
    either the data or rpx file.

    I have run filemon and regmon and compared the outputs and there is nothing which would indicate a problem.





    Anyone got any ideas.



    Jonathan


  • Replied 4 August 2017, 2:47 pm EST

    The first thing I would like to recommend is doing a full search on the
    customer's machine (be sure to include hidden and system files) for
    actrpt2.dll (standard edtion) and arpro2.dll (pro edition).  If
    the customer has any builds of either file that does not match your own
    build and edition, let me know.



    A common cause of error 5000 is antivirus software that blocks
    script.  Try to disable all antivirus software and run the report
    again.



    I also would like to suggest checking the version of the customer's MDAC:

    http://www.microsoft.com/downloads/details.aspx?familyid=8F0A8DF6-4A21-4B43-BF53-14332EF092C9&displaylang=en


  • Replied 4 August 2017, 2:47 pm EST

    actrpt2 is not present on either PC. arpro2 is the same build (1253) on
    the customer and our dev Pc. AS i said i have run regmon and filemon
    and cant see any obviose failures or anything that may cause the
    problem. Reports with only 1 line in the details section print OK. Any
    other number of lines and it fails.



    I dont want to upgrade AR on a 'well it might fix it' basis becase the
    last time we did an update  we had major problems with reports
    contained in dll files hanging and had to go back to this build (which
    seems quite stable in general).



    Any other ideas?



    Jonathan


  • Replied 4 August 2017, 2:47 pm EST

    Sorted this now.

    When the user said they removed the antivirus they obviosly had only
    dissabled it. I had personally tried to dissable it (in fact turned
    every option off and stopped its process) previosly but still had the
    problem.



    I have now removed the AV software for them and everything is working
    perfectly. Probably no surprise when i say the AV software was
    Kaspersky.



    I really think somebody needs to do some testing as to why this
    particular AV software interacts with active reports in this way. There
    seems to be a few posts related to it and its obviosly not as simple as
    a problem scripting.



    To be honest i think this should be raised as an issue and that you do
    some extensive testing on the problem. Our customer has already asked
    for details (which we obviosly cant give them) and now are left with
    simply saying our product is not compatible with systems running this
    AV software. Not really a situation we want to be in.



    Regards










  • Replied 4 August 2017, 2:47 pm EST

    If only it was a perfect world....until then we have Microsoft, Windows, viruses and anti-virus programs. The DD team has AR running off the basic Windows Scripting host that should be present on all windows systems. Now if an AV program turns that off, there is not a whole lot the DD team can do, though I may be missing something here. http://www.datadynamics.com/forums/81738/ShowPost.aspx

  • Replied 4 August 2017, 2:47 pm EST

    The problem is that this isnt related directly to the scripting. Yes
    the report has scripts but it worked providing there was only one
    detail line but not if there was more than one. The AV program
    concerned is mentioned in several other posts here. Even DISSABLING ALL
    the functions of this particular AV program to the point that it was
    doing nothing did not change the problem running reports. Only complete
    removal of the AV software fixed the problem. We have done several
    installations on PC's with other AV software were we have had to turn
    off the script protection and everything has then gone OK.



    In this case it seems obviose that this particular AV software is
    interacting with Active Reports on an entirely different level. Whats
    more it seems from the number of references to it that this problem
    should be quite easily repeatable and should be investigated even if it
    is just to justify to our customers why the problem occurs.



    In general if an AV program has script blocking then you either turn it
    off or dont use scripts but in this case if you use this brand of AV
    software you CANNOT run Active Reports with any reliability and that is
    really not acceptable.





    Jonathan


  • Replied 4 August 2017, 2:47 pm EST

    They do have antivirus but it has been un-installed and the report
    still failed. The MDAC version is 2.8 which is the same as we have here.

    I will Look for the 2 other files tomorrow.



    Cheers




  • Replied 4 August 2017, 2:47 pm EST

    If you would like to attach a sample project that you've seen fail when
    Kaspersky is installed, I will try to set up a test environment to
    reproduce this issue.  Once that's done I'll have development take
    a look and see if anything can be done on our end or at least get a
    more detailed explanation as to why this fails.
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels