Image embedded in EXCEL hide data

Posted by: philippenaranjo on 4 August 2017, 3:13 pm EST

  • Posted 4 August 2017, 3:13 pm EST

    Hi,

    In my report, i have a logo at the top of the page but when i'm exporting my report to EXCEL, the logo will be displayed over the first rows. Is there a property or a deign pattern that need to be done to prevent this.
  • Replied 4 August 2017, 3:13 pm EST

    philippenaranjo,
    Unfortunately, I have been unable to reproduce the described behavior.  In my testing, the image has covered the first few rows of the excel sheet but all of the data was displayed properly.  I would recommend that you ensure you are using the latest build (currently 2.5.0.1314 available for download here: http://www.datadynamics.com/forums/37/ShowForum.aspx).  If upgrading does not help to resolve the issue could you please provide me with an RPX and RDF of a report which would help me to reproduce the behavior.

    You can find additional details on saving RPX and RDF files in the documentation here:
    http://www.datadynamics.com/Help/AR2Std/HX_Saving_and_Loading_Report_Layouts.html
    http://www.datadynamics.com/Help/AR2Std/HX_Saving_And_Loading_RDF_Files.html
  • Replied 4 August 2017, 3:13 pm EST

    Here it is !
    thanks

    2008/12/Bug.zip
  • Replied 4 August 2017, 3:13 pm EST

    Thank you for your reply. Unfortunately, I have been unable to reproduce the described behavior using Excel 2007 with Nicks sample. Does the sample Nick provided work well in you testing? If the sample does not accurately represent your scenario could you please either modify it to demonstrate what you are seeing or localize your sample down as simple as possible to demonstrate the issue?

    Thanks,
        Eric

  • Replied 4 August 2017, 3:13 pm EST

    I have Excel 2007
  • Replied 4 August 2017, 3:13 pm EST

    The sample from Nick gives me the same problem

    I included the snap shot.

    Thanks

    2008/12/AR2ImgExcelBug.JPG
  • Replied 4 August 2017, 3:13 pm EST

    philippenaranjo,
    Unfortunately, I have been unable to even export the report (loaded from the RDF) to excel as the RDF file appears to be corrupt.  Likewise, I have been unable to reproduce the behavior when using the same layout or a similar layout.  In my testing (using the latest build 2.5.0.1314) when exporting the report to excel the image has not overlapped any of the data displayed in the report.  I would recommend that you ensure you are using the latest build.  If you still encounter difficulty when using the latest build, could you please modify the attached sample to reproduce the problem.

    2008/12/AR2Img.zip
  • Replied 4 August 2017, 3:13 pm EST

    Hi
    I'm using the latest build 2.5.0.1314. Here is my prjoect.
    thanks again for the quick respond

    2008/12/exhibitsAcquiredBy.zip
  • Replied 4 August 2017, 3:13 pm EST

    philippenaranjo,
    Unfortunately, I still have been unable to reproduce the described behavior.  In my testing, I have been using Excel 2003 SP3 .  Which version of Excel are you encountering the problem with?

  • Replied 4 August 2017, 3:13 pm EST

    Hi,

    After testing on several other system, the problem is always present. This is not related to my PC.

    Thanks
    Philippe

  • Replied 4 August 2017, 3:13 pm EST

    Windows XP Professional 2002 SP 2 Build 2600
    Excel 2007   12.0.6323.5000  MSO 12.0.6213.1000
        No Application Add-In

    Problem is present in all report generated with my application. 





  • Replied 4 August 2017, 3:13 pm EST

    Thank you for your reply. In my testing I am using Windows XP SP2 and MS Excel 2007 (12.0.6323.5000) MSO (12.0.6036.5000).
    Please ensure you have the latest office updates available. Unfortunately, machine specific issues are often difficult to diagnose if we are unable to replicate the exact environmental variables to reproduce the behavior. With that said I recommend using the Spreadbuilder approach if the latest office updates do not resolve the issue you are seeing. You can find some additional information about the Spreadbuilder API here:

    http://www.datadynamics.com/Help/AR2Exports/HX_Working_with_SpreadBuilder_sheets.html

    http://www.datadynamics.com/Help/AR2Exports/HX_SpreadBuilder_API_Constants.htm.html

    Thanks,
        Eric

  • Replied 4 August 2017, 3:13 pm EST

    philippenaranjo,
    What version of the excel export dll (exclexpt.dll) are you using?  Please ensure that the version and build number of the excel export dll you are referencing match the version and build of ActiveReports you are using. The dlls are typically installed to C:\Program Files\Common Files\Data Dynamics\ActiveReports 2 or C:\Program Files\Common Files\Data Dynamics\ActiveReports Pro.  In my testing I have been using 2.5.0.1314 of both ActiveReports and the excel export dll.
  • Replied 4 August 2017, 3:13 pm EST

    My version of the excel export dll is 2.5.0.1314.

  • Replied 4 August 2017, 3:13 pm EST

    Thank you for your reply. Unfortunately, I am not sure what may be different between our machines as I do not experience the behavior using Excel 2007. Do you only experience issues in that one application, or all applications? Have you tested this behavior on other machines to determine if it is a machine specific issue? Could you please provide me with some information about your machine and service packs so that I may attempt to determine what may be different?

    Also, an alternative approach would be to use the Spreadbuilder API to have full control over the Excel export as the one provided is not 100% WYSIWYG.

    Thanks,
        Eric

  • Replied 4 August 2017, 3:13 pm EST

    Thank you for your reply. Unfortunately, I am unable to reproduce the behavior displayed in your screen shot using Excel 2007 and AR build 1314. Attached is the Excel file generated on my system. Please ensure you do not have an older version of any of the ActiveReports DLL’s registered on your system (including the exclexpt.dll). You can do this by doing a full system search for the DLL and ensure the 1314 ones are the only ones present.

    If this does not help could you please provide me with any additional you may have that could help me replicate the issue in a testing environment (System service packs, software versions, etc…)?

    Also could you perhaps provide me with the RDF of Nicks sample report so I can see how the report was run on your system and attempt to export it?

    Thanks,
        Eric


    2008/12/TestingExportAndScreenShot.zip
  • Replied 4 August 2017, 3:13 pm EST

    If you look at one of my reply to this post, you will see the problem.

    thanks
  • Replied 4 August 2017, 3:13 pm EST

    Thank you for your reply. Could you please provide me with a small running sample that demonstrates the issue you are encountering, or modify the one provided by Nick to demonstrate the behavior?

    Thanks,
        Eric

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels