Java Viewer Exception

Posted by: toddwprice on 4 August 2017, 2:36 pm EST

  • Posted 4 August 2017, 2:36 pm EST

    I'm getting the following error message when I view the results of a report with the Java viewer:

    An error has occurred.  See below for details:

    [ActiveReportsViewer.Start()]: Error loading page data, or TOC data...
    com.datadynamics.activereports.DDIOException: [DDPages.readReportDataFrom]: Error while attempting to read page [0] [zero based].

    com.datadynamics.activereports.DDInvalidCanvasSignatureException:  Invalid Canvas Signature Found.
    [DDPage.ReadCanvasData()]: Invalid signature found reading byte [0].  Found:[0]  Expecting:[112].  Next 16 bytes follow: {I didn't feel like typing this...couldn't copy and paste from the Java viewer...}

    The report does render Japanese characters, so I don't know if this is part of the problem.  Please let me know if you have any suggestions.  Thanks.

  • Replied 4 August 2017, 2:36 pm EST

    Just to clarify, I went back and ran the report in English, and I get the exact same error message.  When I export the report to PDF, it renders fine.
  • Replied 4 August 2017, 2:36 pm EST

    Another follow-up: when I replace my report rdf file with the INVOICE.rdf in the samples folder, the java viewer displays it just fine.  However, my report's rdf file displays fine in the ActiveX viewer, even in Japanese.  Thoughts?

    While I'm thinking about it, does this viewer require a particular VM to run correctly?
  • Replied 4 August 2017, 2:36 pm EST

    Here's an updated java viewer that should work with the latest Sun VM.

    2005/05/Updated Java Viewer Sample.zip
  • Replied 4 August 2017, 2:36 pm EST

    I'm still getting the same error message after replacing the existing arviewer.jar file.  Do I need to do something else to make sure the new version is pushed to the browser? 

    I'm attaching my rdf file in case that helps.  Thanks.

    2005/05/40715_3.rdf
  • Replied 4 August 2017, 2:36 pm EST

    Todd,

    It was actually the Applet tag that was updated in the JavaViewer.HTM file, as well as some of the JavaScript for the sample. You need to grab this new tag to insert on your webpage. Hopefully this will resolve the issue.

    I tested out your RDF file and it loaded correctly, although some fonts were missing. What language setting are you using? Do I need any special fonts etc. to reproduce the issue? Test the issue after updating your applet tag, and if it still occurs please provide any language settings/fonts needed to reproduce the issue.

    Thanks,


Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels