New Active Reports not being saved

Posted by: zozo05 on 4 August 2017, 2:59 pm EST

  • Posted 4 August 2017, 2:59 pm EST

    Hello,


    Previously I was able to create active reports using ActiveReports 2.0 in Visual Basic 6.  For some odd reason, now I can create active reports but when I try to save them, they don't get saved.  It will appear that the new active report was saved but when I go look into the folder that I save the new active report to, it isn't there. 


    I have reinstalled both ActiveReports 6.0 and Visual Basic 6 numerous times and the problem still occurs.  Also I have uninstalled both  ActiveReports 6.0 and Visual Basic 6 and reinstalled them afterwards to not avail.


    Can someone tell me how to fix this issue?  I would greatly appreciate it.


    Thanks.

  • Replied 4 August 2017, 2:59 pm EST

    You say a hardware problem.  I think it is the software.  Not to say your judgement isn't correct but I have been going at this for 2 weeks now.  When it first started I created 2 new reports before I started on a 3rd report and that is when the problems started to occur.  Also sometimes I am able to save the DSR file but the RPX file won't save.  So I am not sure what it is.  I will try your suggestion of checking the hardware of the hard disk.
  • Replied 4 August 2017, 2:59 pm EST

    I am attempting to save the actual RPX file on the hard drive but it seems as if it saves it.  But when I go to the location of where I want to save the RPX file it isn't there.  I even tried to save over an existing RPX file with the same name & it still didn't save.  After I attempted to save the RPX file.  I then tried to save the DSR file.  That doesn't save either but throughout this whole ordeal I have been going through the DSR file has saved a few times but the majority of the time VB6 will lock up(freeze) or it will generate an error and close out.  When I try to debug the error I get this message   Unhandled exception in VB6.EXE (ARPR02.DLL): 0xC0000005: Access Violation.  I tried to google the error message but the results of the search didn't really tell me anything.  I am assumming it was a dll issue which was why I reinstalled both the ActiveReports software and the VB6 software.
  • Replied 4 August 2017, 2:59 pm EST

    Do you mean save the report definition when you save your project or the RPX file? Do you have any problem with saving forms or any other files in other software? where do you save to the hard disk or to a network share? What if you use Save As and save to another location other than the project's location, do you find the report?
    Or do you mean saving the report output (RDF)? If that is the case, what code are you using?
  • Replied 4 August 2017, 2:59 pm EST

    I am not aware of such a problem and since ActiveReports saves to the hard disk through the operating system like any other software, it can't be a problem in ActiveReports. I suggest that you do a thorough check for your hard disk because I think this is a hard ware problem.
  • Replied 4 August 2017, 2:59 pm EST

    In my installation I have in the dialog Help-->About:

    Microsoft Visual Basic 6.0 (SP6)  --> at the top
    Version 9782      VBA Retail: 6.0.9782 ...

    I understand what you have been through already but I believe it is worth it to try to download and install SP6 since it generally good to have and it might solve the problem. Speaking of versions, are you using the latest build of ActiveReports?
    The problem is that this problem is local to your machine and not something that I can reproduce or that there is an indication that it is a problem with ActiveReports. That's why I can only suggest things to try.
  • Replied 4 August 2017, 2:59 pm EST

    I am not excluding the possibility that it could be a problem with ActiveReports, but we need to make sure that it is not a hardware problem. Do you see anything in the event log after the access violation error? You might also want to try to use the Dr. Watson utility to check the problem. Which service pack do you have installed for Visual Basic?
  • Replied 4 August 2017, 2:59 pm EST

    I checked the event log and it displayed a few error messages pertaining to this issue.


      They were:


    Hanging application VB6.EXE, version 6.0.81.76, hang module hungapp, version 0.0.0.0, hang address 0x00000000.


    Faulting application vb6.exe, version 6.0.81.76, faulting module ntdll.dll, version 5.1.2600.2180, fault address 0x00011404.


    I am not sure about the service pack for Visual Basic but I do have Windows XP Profession service pack 2 installed.  Where would I find the service pack for Visual Basic?


    I have tried Dr.Watsons utility but the last issue on the dr.watsons log is from earlier this year.  It doesn't tell me anything about the issue I am having.  I am still using these options to try to find out what is wrong.

  • Replied 4 August 2017, 2:59 pm EST

    In Visual Basic, go to Help About to find out which service pack is installed. You might want to install SP6 if you don't have it and see if it solves the problem. Did you do a hardware check?
    As to Dr. Watson, you can start it from:
    Start-->Run--> drwtsn32

    And save the RPX from inside the IDE to get the error. I am not an expert in reading Dr. Watson's logs but you can post the log here and I will try to help.
  • Replied 4 August 2017, 2:59 pm EST

    I completely understand.  I downloaded and installed SP6 but to not avail.  It still isn't working.  I will try to see if I have the latest version of ActiveReports.
  • Replied 4 August 2017, 2:59 pm EST

    I have checked the event log and I did the Dr. Watson utility and the last error was earlier this year.  I think I already have SP6 installed.  Under VB  help it has:  Version 8176  VBA: Retail 6.0.8169.  I am assumming that is SP6.  I really don't know what else to do.
  • Replied 4 August 2017, 2:59 pm EST

    Well downloading the 2.4.1.1283 version did help.  I can now save new Active Reports but i get a error message when I run the new report.  The error message is:  

    ActiveReportsPDFExport.ARExportPDF error '80004005'

    ActiveReports PDF export DLL error Pages collection contains 0 pages. Export Fails


    Also the error generated at the line:   vByte=arptserver.ExportToByteArray("PDF", cstr(strConnection), cstr(sql))


     


    So it appears that it may be something with the dll.

  • Replied 4 August 2017, 2:59 pm EST

    Check the version in the "C:\Program Files\Common Files\Data Dynamics\ActiveReports.." folder. If you don't have build 2.4.1.1283 download and install it.
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels