PDF formatting changes on various computers

Posted by: jfcs on 4 August 2017, 3:03 pm EST

  • Posted 4 August 2017, 3:03 pm EST

    In our development environment, we have a project that two computers can compile and view correctly. However, when we copy the DLL to another system (all identical images) the PDF formatting is messed up. Instead of alpha-numeric characters, it's either random things (like u4ber or eoFooter) or the ASCII code for unknown characters. The font we're using is Arial. If we export the report to CSV, all of the underlying data is correct...so this issue is only when viewing the PDF. I've tried deleting and recreating the fields...but get the same result.



    Why would this occur? We're all using v2.4.0.1279.



    In this same report, I'm dynamically creating additional fields, which also contain OutputFormatting...but they appear fine.
  • Replied 4 August 2017, 3:03 pm EST

    Please try the export with SemiDelimitedNeverEmbedFonts property of the PDF export set to an empty string:

     myPDFExport.SemiDelimitedNeverEmbedFonts = ""

    also consider upgrading to the lasted build, you can find it here:

    http://www.datadynamics.com/forums/37/ShowForum.aspx
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels