Print dialog does not reflect proper page range

Posted by: neal007 on 4 August 2017, 2:53 pm EST

  • Posted 4 August 2017, 2:53 pm EST

    I am combining two reports using the pages.insert method.  Take for example I have a two page report, when clicking the print button on my toolbar, I see a print dialog that comes up with the option to print page 1-2 (range).  If I add one page to the start using the code below, and go to print again, I still see 1-2, so it's not detecting the added pages.


        Dim rpt As New DDActiveReports2.ActiveReport
        rpt.Printer.Orientation = ddOLandscape
        rpt.Run False
       
        Me.arvCombined.Pages.Insert 0, rpt.Pages(0)
        Me.arvCombined.Pages.Commit
        Set rpt = Nothing


    Also, I'd like the print dialog to appear with the ALL pages option selected.  How do I get this instead of the page RANGE to be the default?


    I'm using AR 2 Pro (latest build)

  • Replied 4 August 2017, 2:53 pm EST

    I found this KB article, will adjust my code:


    http://www.datadynamics.com/forums/86/ShowPost.aspx


    Now searching on how to get the ALL option to be selected.

  • Replied 4 August 2017, 2:53 pm EST

    Okay, so I did the above KB article setting the printer.topages (or whatever it was) to the pages.count.  Now, when going to print the report, the printer dialog only has the ALL option selected.  The page range option is NOT available now!!!
  • Replied 4 August 2017, 2:53 pm EST

    I fixed the issue it looks like!  If you set the ToPage you better set the FromPage to 1 or the selection option is not available and ALL is set by default.
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels