Printer error 482 - reprise

Posted by: scottvandenelzen-com on 4 August 2017, 2:40 pm EST

  • Posted 4 August 2017, 2:40 pm EST

    Hi All-

    I've found a consistent way to cause a 482 printer error & a couple of ways to fix it.  I thought I'd post it here so the DD people can try to find the problem.

    Start with a Win2003 Server.  Install a DLL that does runs your ActiveReports and sends them directly to a printer.

    NOW... Upgrade it to Windows 2003 Service pack 1 and you'll get the 482 printer error.  I've done this with 3 servers and it happens every time.

    If I then make the IUSR_Computername account a part of the administrators group - this usually fixes the problem.  So it's obviously something the service pack changes on the security side.

    The last time I had the problem, even this didn't work.  I had to change the user in the IIS snapin to 'Administrator'.  This worked.  Then I was able to change it to IUSR_Comutername and it did work. 

    Yes - I know it doesn't make any sense but there it is...

    Let me know if I can provide any help debugging this mess.

    Thanks,

    Scott
  • Replied 4 August 2017, 2:40 pm EST

    AngryHi PeterDD,

    Which CR# took this problem?
  • Replied 4 August 2017, 2:40 pm EST

    scottvan was posting an experience he had with setting up permissions for his printer while setting up ActiveReports on a Windows 2003 server.  He found a helpful workaround to the security settings in IIS.  I thank him again for posting.

    I did not see any indication in this post that this difficulty pertains in any way to ActiveReports.  He describes two configurations that should produce exactly the same results, but do not.  This is a Microsoft issue.  If scottvan has an additional question for ActiveReports or suspects ActiveReports is responsible for this, I invite him to post again. 
  • Replied 4 August 2017, 2:40 pm EST

    Thank you very much for this information.  I'm sure this will come in handy to many users!
  • Replied 4 August 2017, 2:40 pm EST

    I am not sure, that this is a Microsoft issue.
  • Replied 4 August 2017, 2:40 pm EST

    Hi All-

    Another fix:

     

    Turning off spooling in the printer driver seemed to fix it without resetting the IIS Permissions.

     

    To do this Start>>Printers and Faxes>>Right click on a printer and choose properties>>Advanced tab>>choose the “Print directly to the printer” radio button.

    Hope this helps somone...

    scott
    Visonex
    http://www.visonex.com

  • Replied 4 August 2017, 2:40 pm EST

    Great Smile  Thanks for the tip.
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels