Report using GroupFooter acting strange

Posted by: jonesedw on 4 August 2017, 2:53 pm EST

  • Posted 4 August 2017, 2:53 pm EST

    The report in question is a Gradebook report. The rows represent students and the columns represent assignment scores. The GroupFooter prints the class average for each assignment. Of course the number of students can vary from class to class. Likewise, the number of assignments varies too. The maximum number of students that fit on a page is 25. The maximum number of score columns is 20. If the class has more the 25 kids, the students spill onto a second page and the footer prints there. If the class has more then 20 assignments, the report processes 25 students at a time and prints all of the assignments for the 25 and the footer then moves to the next 25 if there are any.

    Now to the problem(s). As I said the cutoff for a page is 25 students. If the class has less then 25 kids, no problem. Everything works fine. If the class has 25 exactly, the class prints on a single page with the footer no problem. Then a blank page prints. If the class has 26 students, page one prints students 1-25 and the report stops. No 26th student and no footer are printed. 27 students print on two pages as expected and there is a footer but the value in the footer is simply a repeat of the 27th students scores and not the class average. Finally, a report with 28 students works perfectly.

    I have played with the GrpKeepTogether, KeepTogether, Repeat and NewPage settings on the GroupHeader and GroupFooter. I can not find the right combination. Currently they are set at

      • GroupHeader.Repeat = 1-Every Page

      • GroupHeader.GrpKeepTogether = 0-None
        <LI>GroupHeader.KeepTogether = False
        <LI>GroupHeader.Repeat = 1-Every Page
        <LI>GroupFooter.KeepTogether = True
        <LI>GroupFooter.NewPage = 2-After

    I should mention that the scores are stores in hidden containers on the GroupFooter and calculated in the OnFormat event. There is other code but it is has to do with the content of the report. Not the control of the report.

    I also tweaked the dimensions of the rows but this only changed the cutoff and the problem remained.

    Could this be a bug or is it simply that my settings are wrong.

  • Replied 4 August 2017, 2:53 pm EST

    The first step is to make sure that you are using the latest hotfix for the product (1283). You can download it here: If this does not resolve the issue, can you please attach your .DSR and .DSX files for the report so that we can take a look at that them?


  • Replied 4 August 2017, 2:53 pm EST

    Thank you. I downloaded and installed the 1283 version but still get the same results. I was at 1268. I have a .RPX file but do not know what .DSR and .DSX files are. Will the .RPX file do? If so, I will have to email it to you. I can not attach it. I get this message when I try to attach it.

    <FONT size=1>

    Your post has been saved, but the attachment was not.

    The administrator has denied uploads of certain file types and the file must have only one extension (filename.ext).

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels