Reports not viewable in viewer

Posted by: jtolar-dd on 4 August 2017, 2:57 pm EST

  • Posted 4 August 2017, 2:57 pm EST

    Today, after my project has been in production for almost a year, Some workstations have problems displaying any reports in the report viewer control. You can press print and the report will print, but will not let you view the contents of the report in the viewer. It just displays a viewer without pages.



    I have not rolled out any changes since thursday. It was tested and verified on thursday. It just started happening on random workstations. As this is a critical peice in the project (Creates and displays internal documents, Account Letters and Audit Reports) I am anxious to resolve this issue.



    Thanks,

    John
  • Replied 4 August 2017, 2:57 pm EST

    It has also come to my attention that the copyright/evaluation notices are showing up on the printed reports. We have a license for the controls. Could this be a part of the problem.
  • Replied 4 August 2017, 2:57 pm EST

    We have noticed that the control has started printing copyright\Evaluation notices on the reports. could this be a cause of the problem or a Symptom?
  • Replied 4 August 2017, 2:57 pm EST



    Hello,



    Most likely you have the evaluation messages because you built / rebuilt the
    project on a machine that is not licensed.  Do the affected computers
    still not see the reports when you registered the DLL's again?



  • Replied 4 August 2017, 2:57 pm EST

    Hello,

    If the users roll back to the original project do they still have problems veiwing the reports?

  • Replied 4 August 2017, 2:57 pm EST

    We are using a custom updated program written in house that only updates components that have changed. It looks at the CRC32 Hash of the file to see if the file has been updated. If it has not, then the control\files do not get updated. This is the same control that has been in production all along. There has not been any changes that would cause this control to be updated. Also, as part of the update procedure, it reports the version of the program back to a database and all workstations are using the same version of the file and program. I am going to go to a workstation that is having the problems and try to re register the control to see if this fixes the problem.
  • Replied 4 August 2017, 2:57 pm EST

    I sent out a refresh of the controls and this fixed the problem, but without having any new versions of the program deployed, this is starting to happen again.
  • Replied 4 August 2017, 2:57 pm EST

    Hello,

    I am sorry, but I do not understand what you mean by 'but without having any new versions of the program deployed, this is starting to happen again'.  Can you please give me more detail about the problem with 'new versions' is?
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels