Run-time Error '-2147024770 (8007007e)': Automation Error The Specified module could not be found.

Posted by: dhirendra on 4 August 2017, 3:18 pm EST

  • Posted 4 August 2017, 3:18 pm EST

    <P><FONT face=Verdana size=2>Hi,</FONT></P>
    <P><FONT face=Verdana size=2>I am using <STRONG>Active Report 2.0</STRONG> for my reporting with<STRONG> Visual Basic 6.0</STRONG>. The application was running fine previously but now it is giving the error while showing/loading the active report.</FONT></P>
    <P><FONT face=Verdana size=2>I am using the application on <STRONG>Citrix Presentation Server</STRONG>. The application run fine in the <STRONG>Windows Server 2003</STRONG> and when we access the same application via <STRONG>Citrix Presentation Server</STRONG>, it gives following error:</FONT></P>
    <P><FONT face=Verdana size=2><STRONG>Run-time Error '-2147024770 (8007007e)':<BR><BR>Automation error<BR>The specified module could not be found.</STRONG></FONT></P>
    <P><FONT face=Verdana size=2>Can you pls suggest what is wrong with the Active Reports while using it via Citrix Presentation Server.</FONT></P>
    <P><FONT face=Verdana size=2>You help will be appreciated.</FONT></P>
    <P><FONT face=Verdana size=2>Thanks in advance,<BR>Dhirendra</FONT></P>
    <P><FONT face=Verdana size=2></FONT> </P>
    <P><FONT face=Verdana size=2></FONT> </P>
    <P><FONT face=Verdana size=2></FONT> </P>
    <P><FONT face=Verdana size=2></FONT> </P>
  • Replied 4 August 2017, 3:18 pm EST

    Hello,<br><br>Thank you for your query. Let me investigate further on this. I will update you soon.<br><br>Regards,<br>Prantik
  • Replied 4 August 2017, 3:18 pm EST

    <P>Hi Prantik,</P>
    <P>Thanks for you reply,</P>
    <P>I am awaiting for your kind response further.</P>
    <P>Dhirendra</P>
    <P> </P>
    <P> </P>
  • Replied 4 August 2017, 3:18 pm EST

    Hello,<br><br>Thank you for your patience. From the error message it seems that the application is unable to find the required dlls. You may try re-registering them or setting proper permissions for them. Moreover, this issue may not be specific to ActiveReports. Please take a look at this and this articles.    <br><br>Regards,<br>Prantik
  • Replied 4 August 2017, 3:18 pm EST

    <P><FONT face=Verdana size=2>Hi,</FONT></P>
    <P><FONT face=Verdana size=2>Thank again for your prompt reply.</FONT></P>
    <P><FONT face=Verdana size=2>By the way I am getting the error on the below statement</FONT></P>
    <P><STRONG><FONT face=Verdana size=2>rptActiveReports.xSQL = "select * from tblperson"</FONT></STRONG></P>
    <P><FONT face=Verdana size=2>In above statement the xSQL is a public string variable in my report which I am assigning here with query "select * from tblperson"</FONT></P>
    <P><FONT face=Verdana size=2>Can you pls also let me know which dll , ocx or runtimes should I see/register for active reports on the Citrix Server Presentation Server. Also for your information as I said in my previous post that the report is working fine on my windows server 2003 which is a base citrix  presentation server.</FONT></P>
    <P><FONT face=Verdana size=2>Pls reply.</FONT></P>
    <P><FONT face=Verdana size=2>Thanks in advance,<BR>Dhirendra</FONT></P>
    <P><FONT face=Verdana size=2></FONT> </P>
    <P> </P>
    <P> </P>
    <P> </P>
  • Replied 4 August 2017, 3:18 pm EST

    Hello,<br><br>I am not very sure of the dlls required by your project. However please take a look at this link which has a list of the ActiveReports dlls and their functionalities.<br><br>Regards,<br>Prantik
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels