Runtime doesn't work

Posted by: ac6305 on 4 August 2017, 3:00 pm EST

  • Posted 4 August 2017, 3:00 pm EST

    Hello,


    I'm using ActiveReports2 standard version. My application is written in Visual Basic6 on Windows XP. In development Environment, I have no problem.


    I have installed the application in a User Acceptance Environment : .exe file in the user directory  + actrpt2.dll in c:\Program Files\Common Files\Data Dynamics\ActiveReports 2


    When I want to execute the report in User Acceptance Environment, a new window is opened (with the name of the report in the title, and the standard buttons of activereports), with no content and  the cursor becomes an hourglass and ... that's all, nothing any more moves.


    Could you help me ?


    Thanks

  • Replied 4 August 2017, 3:00 pm EST



    The report could be unable to connect to the data source or something wrong in the code of the report could be causing the hang or some other reason. Try to get any error message or information so that
    we could be able to assist you. For example, you could kill the hanging process
    from Task Manager and look in the Event Log for any message related to this
    application. Although I haven’t examined a Dr Watson log before, you can
    start this utility before killing the process and see if you find anything in
    it’s log after the crash.



    Try also to add an error handler in your code before you run
    the report and display it in the viewer so that you get any message about what
    is causing the application to hang. If you find any helpful information post it here, possibly with the DSR/DSX files of the report and we will try to help.

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels