Script error but no script

Posted by: chris94 on 4 August 2017, 3:15 pm EST

  • Posted 4 August 2017, 3:15 pm EST

    I have downloaded latest version AR2 (using VB6 SP5, XPpro SP3) to evaluate. Using the Simple Designer sample, and loading sample RPX AlphabeticalListOfProducts.

    I have changed the Datactrl to point to NWind Db on my PC but made no other changes.

    When I click on Preview tab, I get error    Error 2108 ......script  ......  Report Header, Event Format, Line 0, "Format"

    There is no script code in any of the events.   There was just this in Report Header:
            Sub  OnFormat
            End Sub

    But I have tried removing even this from all events, so there is no script text at all in this report.  But I still get the above error.

    Help please.   

    (I have useed AR1 for many years so I am familiar with it. But I have to say I am disappointed so far with documentation and samples of AR2.)

    PS.  more information.  Using the Diamond Reports sample, the above report works fine and gives no error.
  • Replied 4 August 2017, 3:15 pm EST

    Hello,



    I am attaching the Sample Designer project herewith. Please run the same and check if you see the error after connecting to the NorthWind Database. Could you please provide us the screenshot of the error?



    Regards,

    Prantik


    2009/05/Simple Designer.zip
  • Replied 4 August 2017, 3:15 pm EST

    I ran the Simple Designer as requested and get the same error.  Screenshots attached.

    If you do not get error when you use Simple Designer with this sample report AlphabeticalListOfProducts, then think what I could have done to give this error. I could attach my copy of the AlphabeticalListOfReports sample for you to try.

    Remember also, this sample report works OK when loaded in Diamond Reports sample.


  • Replied 4 August 2017, 3:15 pm EST

    Hello,



    The error that you mentioned is triggered due to some script in your report. Please check the following article in this regard.



    http://www.datadynamics.com/forums/50028/ShowPost.aspx



    If the issue persists, could you please attach the RPX of your report so that we can resolve the issue?



    Regards,

    Prantik

  • Replied 4 August 2017, 3:15 pm EST

    I checked the article and cannot find any script at all in my report. The report is one of your samples, downloaded from your website. I can attach it if required but I thought you would have a copy.

    Note: This same report does work OK in Diamond Reports sample app.
  • Replied 4 August 2017, 3:15 pm EST

    Chris,



    From the screenshot it seems that you are using some calculated expressions in the datafield of some controls. In order to resolve this issue, would it be possible for you to save the report design that the screenshot displays as RPX and send us the same?



    Regards,

    Prantik

  • Replied 4 August 2017, 3:15 pm EST

    Dear Prantik
    The report is your sample report AlphabeticalListOfProducts.rpx

    I have attached it here.  Hope this enables you to see what I am doing wrong.

    Regards
    Chris

    2009/05/AlphabeticalListofProducts.rpx
  • Replied 4 August 2017, 3:15 pm EST

    Chris,



    I have modified the datafield property of the Field DatePrinted and the report displays properly at my end. Please modify the connection properties of the Datacontrol to connect to the NorthWind Database in your system. Please let us know if you need any further assistance/clarifications.



    Regards,

    Prantik




    2009/05/RPx.zip
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels