Issues with the AutoComplete control in the latest build 2018 V2

Posted by: stevecarmichelle1 on 25 July 2018, 8:30 am EST

  • Posted 25 July 2018, 8:30 am EST

    Hi Kelley,

    I updated my version to 2018 V2 and found that the following issues happen which affect the over all behavior of the AutoComplete Control.

    1. When setting the DropDownMode="ForceAbove", AutoCompleteMode="StartsWith" and ShowClearButton="True" the following issues happen.

    I enter the first few character, and the filter works fine. I am able to select the word which has filtered to one choice. Then I tap the clear button and the contents are cleared but now the Dropdown mode is back to default (dropping down). And typing shows the drop down below the edit control. The ForceAbove does not work again.

    2. When the ShowClearButton="True" is enabled, and on erasing the content, I am unable to select the value from the drop down list after typing the first few characters. This causes the application to hang. Sometimes the drop down hangs after tapping the Clear button. The application is rendered as non functioning at this stage.

    3. The mode DropDownMode="ForceAbove" does not work again after selecting a new value again.It defaults to the original mode "Default"

    4. After erasing the value with the clear button, the full list is no longer visible and only one row is visible in the drop down.

    This has affected the functioning of our application with the latest build and we have reverted to the previous build which is working fine.

    Thanks,

    Rajesh
  • Replied 25 July 2018, 12:55 pm EST

    Hi Rajesh

    Which platforms did you see this behavior in? I tried to replicate your behavior, but I didn't see exactly what you described (though I did run into a couple of issues I'm going to have the developers look at). Let me know when you have a chance. In the mean time I've filed an issue for suggestions not appearing when ForceAbove is used with an ItemTemplate and the user has typed some text, as well as an issue where ForceAbove isn't working on UWP.

    Thanks

    Kelley
  • Replied 25 July 2018, 10:05 pm EST

    Hi Kelley,

    I experienced all of these problems in iOS platform with .Net Standard 2.0. using iOS SDK 11 and targetting iOS 11.1 platform.

    Thanks,

  • Replied 26 July 2018, 5:41 am EST

    Hi Kelley,

    I am sending my sample project to demonstrate the bugs as submitted yesterday. This is the same project that I send a few weeks back. This is developed on Visual Studio 2017 and targeting .net standard 2.0. This will also work in VS for Mac. A video is also attached that shows the behavior. This project is focused for ios platform only.

    This has been updated to the latest build ComponentOne 2018 v2 and uses AutocompleteMode and ShowCloseButton

    I noticed some differences between selecting the values from the drop down and typing with the keyboard.

    If we just select a value from the drop down , then delete it and it shows ALL the values again.

    But if we type the first few characters and then select the value, and then delete it and the drop down shows only one row. Typing will show the filtered value but the issue is that all the values are not displayed in the drop down.

    Thanks,

    Rajesh
  • Replied 26 July 2018, 5:43 am EST

    attachment attached.
  • Replied 31 July 2018, 3:40 pm EST

    Hi Rajesh

    I don't think your video came through. I can reproduce issue 4, but I'm still not seeing the rest. If the video is too large maybe you can try sending a snippet of the project instead. I'll go ahead and talk to the developers about issue 4 though.

    Thanks

    Kelley
  • Replied 1 August 2018, 9:21 am EST

    Hi Kelley,

    I am sending the source code as a full VS project along with the video inside. Shows that the attachment is 4.1 Mb. Please let me know if you have received this. How do I know that the attachment has been uploaded along with this.

    Thanks,

    Rajesh.AutoCompleteWithFiltering2018v2 .zip
  • Replied 1 August 2018, 9:41 am EST

    I got it this time, Rajesh. I'll take a look.

    Thanks

    Kelley
  • Replied 27 August 2018, 2:03 am EST

    Hi Kelley,

    Has there been any updates to the latest release of AutoComplete control related to filtering.

    Thanks,

    Rajesh
  • Replied 30 August 2018, 11:01 am EST

    Hi Rajesh

    We've fixed a few bugs related to the Input controls, and we should drop another hotfix relatively soon (my guess is probably next week though it depends on QA). I'll let you know.

    Kelley
  • Replied 4 September 2018, 12:14 pm EST

    Hi Kelley,

    For now we are adjusting without the filter clause "Starts With" which helps faster but the performance and loading of huge data in them is important for us and so we are happy.

    Glad to hear that a new build is expected. Looking forward to improved functionality for these controls.

    Thanks,

    Rajesh.
  • Replied 26 September 2018, 5:21 am EST

    Hi Rajesh

    We just released build 318 which should have a fix for your problem. The release took a little longer than anticipated since we also ended up testing against Xamarin.Forms and iOS updates. Let me know if you see any problems.

    Kelley
  • Replied 26 September 2018, 11:37 pm EST

    Hi Kelley,

    I would like to know if there is any issue in just upgrading the controls in Visual Studio. Right click on the component in nuget and then update. but when building sometimes it doesn't get refreshed and the old behavior still persists.

    Can you please let me know apart from clearing the bin and obj folders is there any way to ensure that the latest dlls are updated in the solution.

    Thanks,

    Rajesh.
  • Replied 27 September 2018, 4:30 am EST

    Hi Rajesh

    I'm not sure about the Visual Studio issue. I have noticed on occasion in VS for Mac that it's sometimes easier to remove the older package references and then add the newest instead. Especially with the Xamarin libraries, it seems to have difficulty resolving the newest Android support libraries at times. There have been a lot of updated libraries in the past month since all of the mobile OS's have been updated, so this seems like a possibility to me. Hopefully that helps out in this circumstance.

    Thanks

    Kelley
  • Replied 1 October 2018, 9:42 am EST

    Hi Kelley.

    I worked with this new build today and found that even Xamarin Forms had to be upgraded to 3.2.0.839982

    Updated C1 components to 3.2.20182.318. This is on a Mac platform and targeting iOS only for now.

    The following was observed.

    1. The positioning of the text edit fits correctly above the keyboard and it does not detach from the text edit when the screen is scrolled.

    2. The always on top or always below works as expected.

    3. When using the mouse to delete the selected value and select a new value it works fine.

    Now the following issues still persists from the previous version.

    1. When the keyboard is used in any scenario, it causes the drop down to lose all the values except the word that starts with the first letter that I type.

    2. When the keyboard is used in any scenario, it resets the drop down direction to always down.

    Kindly let me know if you are able to view the following issues even with the latest build. The biggest requirement for the usage of the keyboard is when the drop down column has 30000 values and they are sorted in alphabetical order. so it tends to give more issues to the user if he sees the values disappearing and having to perform a guess to know the exact value.

    Looking forward to hearing your reply about this keyboard issue.

    Thanks,

    Rajesh.

  • Replied 4 October 2018, 3:10 pm EST

    Hi Rajesh

    We have a sample in Input101 that would probably be helpful for your use case. Take a look at the AutoComplete sample, but more specifically look at the last AutoComplete that uses dynamic filtering. This sample uses a cursor based CollectionView to incrementally load results from YouTube. It's a similar scenario where you may have thousands of potential results.

    I'll take a look at those bugs and see if I can reproduce them here.

    Thanks

    Kelley
  • Replied 10 October 2018, 12:09 pm EST

    Hi Kelley,

    Can you please let me know where that Sample in Input 101 is located. I couldnt find anything related to Xamarin forms and there were certain samples for Android and iOS only.

    And I would like to make my point clear.

    The issue that I highlighted regarding the keyboard has no impact on the performance . Loading of data is very good especially when having 10 drop downs in a single page. The only issue is the inability to show all the data in the drop down back once the textbox is cleared.

    Thanks,

    Rajesh.

  • Replied 11 October 2018, 3:18 pm EST

    Hi Rajesh

    I was referring to the AutoCompleteSample in C1Input101.

    https://github.com/GoXuni/C1-Studio-for-Xamarin/blob/master/XF/C1Input101/C1Input101.XF/View/AutoCompleteSample.xaml

    https://github.com/GoXuni/C1-Studio-for-Xamarin/blob/master/XF/C1Input101/C1Input101.XF/View/AutoCompleteSample.xaml.cs

    And the YouTubeCollectionView

    https://github.com/GoXuni/C1-Studio-for-Xamarin/blob/master/XF/C1Input101/C1Input101.XF/View/YouTubeCollectionView.cs

    However if I understand correctly you're actually talking about the behavior that the DropDown closes once you clear the text? I think that's just a function of the MinLength property. Try setting it equal to 0 and see if that's the behavior you're looking for.

    Also one final note, there is a bug with the clear button where the DropDown doesn't update and repopulate with terms after the clear button is pressed. We should have a fix for that in an upcoming build. Let me know if this last case is what you're referring to.

    Thanks

    Kelley
  • Replied 19 October 2018, 2:01 am EST

    Hi,

    Also one final note, there is a bug with the clear button where the DropDown doesn't update and repopulate with terms after the clear button is pressed.

    This is the bugi am facing, if the delete button is used to erase the selected value or the backspace is used to erase the letters the contents of the Dropdown are cleared.

    Thanks,
  • Replied 29 October 2018, 11:13 am EST

    Hi Rajesh

    I'll let you know once I have a stable build with the fix in it. Because of the timing, the fix will be included into our 2018v3 release (which will be released at the end of the month), but I can provide a build ahead of time for you once it's passed QA. Hopefully that should not take too much longer.

    Thanks

    Kelley
  • Replied 19 November 2018, 2:51 pm EST

    Hi Rajesh

    When you have a chance, check out the 2018v3 build 3.2.20183.344. It should have a fix for your issue, as well as enhancements to the full screen mode on iOS.

    Kelley
  • Replied 20 November 2018, 2:53 am EST

    Hi Kelley,

    I migrated my application to the latest version 3.2.20183.344

    And found that there are some minor issues regarding the selection, deleting and populating.

    Sending the latest code with the updated nuget packages.

    Some of the errors that i get are.

    1. Enter some values and select one from the drop down. Using the delete button on the autocomplete control. delete the data and it crashes with this error

    System.ArgumentNullException:Value cannot be null
    Parameter name: fromPosition

    2. Sometimes the application hangs when trying to change the selected value from the drop down. It hangs for a while and then crashes.

    3. Having issues when trying to use the filtering clause to see the drop down to select a different value that starts with the same alphabet.

    Hope that the source code provided will help you to determine the cause of the crashes. Screen shot of the error is provided in the zip attachment.

    Thanks,

    RajeshAutoCompleteWithFilteringNovember2018.zip
  • Replied 13 December 2018, 12:00 am EST

    Hi Kelley,

    Have you been able to reproduce the bugs that I have submitted. Please let me know if this issue still persists and what can be done to make ti work without any problems.

    thanks,
  • Replied 27 December 2018, 11:20 am EST

    Hi Rajesh

    I've been trying to reproduce these issues, but I can't on my machine here. Do these happen under a specific circumstance (only on device for instance). Also is this just iOS or are you testing on another platform?

    Thanks

    Kelley
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels