Can not use FpSpread trial

Posted by: silk on 8 September 2017, 12:56 pm EST

  • Posted 8 September 2017, 12:56 pm EST

    Hello,


    I have installed FpSpread v3.0 trial. I have installed it properly and added FpSpread to the Toolbox. Though, when I drag the component to my form I get the following exception:

    Failed to create component 'FpSpread'. The error message follows:

    'System.UnauthorizedAccessException: Access to the registry key 'HKEY_CLASSES_ROOT\-----------' is denied.

    I am using Visual Studio 2008 and Vista. My account is running with administrator privileges. You got any ideas of what to do?


     


    Thanks,


    Johan

  • Replied 8 September 2017, 12:56 pm EST

    I was not at first but now I have tried doing that and that seems to solve the first problem.


     


    Though I do get the same error no matter if I use VS2005 or VS2008 as administrator. When I open the Spread Designer I get the mentioned exception and I get the same exception when I try to close it aswell. On top of that I can not exit the Spread Designer without getting the exception. When I get asked if I want to save changes I get the exception no matter what option I choose (Yes/No/Cancel). This means I have to exit the entire Visual Studio application via terminating the process since I can not get the Spread Designer to exit :P This is not very good at all...

  • Replied 8 September 2017, 12:56 pm EST

    Hello,


    Are you running the Visual Studio 2008 in Administrative mode? Right click on the exe and select the Run As Administrator option. I tested this and it worked correctly.

  • Replied 8 September 2017, 12:56 pm EST

    I tried it using Visual Studio 2005 now. This time the "Activate Trial" form appear and after that the splash screen for the Spread Designer loads. When I press OK on that form I get the following exception (the Spread Designer does load after clicking continue on the error though...):


     

     
    System.InvalidCastException: Unable to cast object of type 'FarPoint.Win.Spread.FpSpread' to type 'FarPoint.Win.Spread.FpSpread'.

    at FarPoint.Win.Spread.Design.DesignerMain.a0(Object A_0, EventArgs A_1)
    at System.Windows.Forms.Form.OnLoad(EventArgs e)
    at System.Windows.Forms.Form.OnCreateControl()
    at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
    at System.Windows.Forms.Control.CreateControl()
    at System.Windows.Forms.Control.WmShowWindow(Message& m)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
    at System.Windows.Forms.ContainerControl.WndProc(Message& m)
    at System.Windows.Forms.Form.WmShowWindow(Message& m)
    at System.Windows.Forms.Form.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
     
  • Replied 8 September 2017, 12:56 pm EST

    Hello,


    It sounds like it is trying to load a different version of the assembly and Spread Designer. Look in your GAC to make sure there is only one version of the Spread assemblies and that this is the one referenced in your project.

  • Replied 8 September 2017, 12:56 pm EST

    Hello,


    If you have Visual Studio 2005 installed, then the gacutil utility should have been found and used. Could you take a look at the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\sdkInstallRootv2.0 key and make sure the directory it points to has a bin directory and in the bin directory is gacutil.exe. As long as that file is there, the Spread assemblies should have installed to the GAC with no problems.

  • Replied 8 September 2017, 12:56 pm EST

    Hello,


    I am glad to hear you were able to track down the issue. This is a serious problem as you point out. We need to find out why you are not able to get the install to work correctly.


    You stated you have Visual Studio 2008 installed. Do you have any other versions of Visual Studio installed? If not, then this is a known problem found a couple of days ago and is now fixed and will be in the next maintenance of all our installs.


    With the release of Visual Studio 2008, the location of gacutil (the utility we use for putting assemblies in the GAC) has been moved. Also, they changed the registry key that we use to find the utility for use during our install.


    I never read any documentation on this during my beta period with VS2008 and it was not until the other day when another customer, who only had VS2008 installed, did we become aware of this issue.


    Thank you for letting us know and I hope the rest of your trial period meets your expectation from us. Have a great day.

  • Replied 8 September 2017, 12:56 pm EST

    I have both Visual Studio 2005 and Visual Studio 2008 installed.


    Please do let me know if you want me to try anything special.

  • Replied 8 September 2017, 12:56 pm EST

    I have now done a little bit more research and it seems that the Spread has not been registered in the GAC at all. I have been looking into some articles and your documentation and it seems Messenger Live can cause some issues with installing and removing from the GAC. I will try to uninstall the Spread and reinstall with Messenger shut down. Will get back with more informatin as soon as I have reinstalled the Spread.
  • Replied 8 September 2017, 12:56 pm EST

    I have now reinstalled the Spread trial but still nothing shows in the GAC.
  • Replied 8 September 2017, 12:56 pm EST

    I had to manually register the assemblies into the GAC and now it is working.


    I love the spread and have been working with previous versions for about 3 years now but these things make people choose other spreads or grids. Right now I am supposed to evaluate and choose a new grid/spread component for my current company but some people are very sceptical when they see all the trouble these things cause. For example the XCeed grid (and other components) has no problems what so ever when installing and is working "out of the box" after installed with both VS2005/2008.


    Though, in the end I think the Spread is a better product but please make sure these things won't happen. Specially not with a trial version as this is the first thing people see... Paying a minimum of $899 per licence for something that has bugs right away even before you can use the product isn't acceptable.


    Hope you guys will sort it out :)

  • Replied 8 September 2017, 12:56 pm EST

    My computer is newly formatted and re-installed and have no other versions installed but this trial.
  • Replied 8 September 2017, 12:56 pm EST

    Hello,


    It is not an issue if you have VS2005 on your computer as well. I have been running this scenario for months using the beta of VS2008.


    It loks like you are having rights issue with the install not having the correct rights to perform these actions. You will need to run this install on the Administrator account. It will not work on another account that is part of the Administrator group. If you do not have the Administrator account enabled on this computer (this is not enabled on default install of Vista), then you can also turn off the UAC during the install on your current account. I would suggest trying this to see if the files install in the GAC and your help file installs correctly.

  • Replied 8 September 2017, 12:56 pm EST

    Everything seems to be in order. The key exists, the path is valid and contains a Bin sub folder with the gacutil.exe inside.


    Can the problem have anything to do with me having two versions of Visual Studio installed at the same time? I know that I have had the VS2005 installed before VS2008 but that shouldn't make any difference.


    I have been looking through the system log and had a look in the FarPoint installation folders for any log files. The system log is fine and only contains events concerning FarPoint when it comes to my installation and removal of the trial version when I was trying to figure out why it wouldn't register in the GAC. Though I have found something strange in one log file in the FarPoint installation folders(C:\Program Files\FarPoint Technologies\Common Files\H2Reg_Log.txt). First it states that I have Internet Explorer 6 installed while I in fact have Internet Explorer 7. This might not matter that much since I guess it is only for the help to determine what browser to use or something like that. But it also states the following error in the very end of the log file:

    10:52:21   ** Error **
    Installation Error. Error reading system file or file not found.
    C:\Program Files\FarPoint Technologies\Common Files\Formula.v3\H2Reg_cmd.ini
    10:52:21 Program Aborted!!

    --END OF FILE--

    The folder Formula.v3 does not exist.


    Hope this helps...

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels