code works fine when debugging.

Posted by: parez81-fp on 8 September 2017, 1:16 pm EST

  • Posted 8 September 2017, 1:16 pm EST

    Hi,

    I have an issue where my code works fine when i am debugging it.

    I have a grid with a  check box column. Every time some checks/unchecks the column, i check every row in the grid for a certain condition.

    Record Status ="yes"
    Determination Date not blank
    Final Det Date not blank.

    If i find a row then i enable a button.

    When debugging, my code which is attached works every time but the checking/unchecking does not happen.
    When i am not stepping thru, the checking/unchecking of the row works but my code does not work.


    Paresh


    2008/06/TestProjectForFp.zip
  • Replied 8 September 2017, 1:16 pm EST

    Try using the ButtonClicked event when checking the checkbox.
  • Replied 8 September 2017, 1:16 pm EST

    Thanks.
    That and some small tweak in my code it works great.
    What was the problem? why does the event gets cancelled?
  • Replied 8 September 2017, 1:16 pm EST

    What event are you talking about? 
  • Replied 8 September 2017, 1:16 pm EST

    The cell click event.
    When I step thru the code after i clicked a checkbox type cell, checking/unchecking does not happen.
  • Replied 8 September 2017, 1:16 pm EST

    Button cell types (e.g. checkbox, button) use different editors so the click event doesn't fire for them.
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels