Issue with Horizontal scroll bar

Posted by: revathy-fp on 8 September 2017, 2:21 pm EST

  • Posted 8 September 2017, 2:21 pm EST

    Hi, 


    While working with .net Farpoint  spread , version 5 , I found the following issue.


    Issue: When the leading columns in a spread are hidden , and the user tries to scroll across the remaining columns ( form width is such that the last column of spread is visible partially) by clicking on the "scroll far" (Zip) button , the scroll does not work. However when the user clicks on the scroll bar (shaft) the scroll works without any issue.



    In my sample WindowsForm application containing a farpoint spread , the issue could be easily seen by adding the below sample code. The horizontal and vertical scroll policy is set to "as needed" and smallchange is set to 1. The scroll bar button set to Lineupdown and thumb.


                this.fpSpread1_Sheet1.ColumnCount = 5;
                this.fpSpread1_Sheet1.SetColumnLabel(0, 0, "1");
                this.fpSpread1_Sheet1.SetColumnVisible(0, false);
                this.fpSpread1_Sheet1.SetColumnLabel(0, 1, "2");
                this.fpSpread1_Sheet1.SetColumnVisible(1, false);
                this.fpSpread1_Sheet1.SetColumnLabel(0, 2, "3");
                this.fpSpread1_Sheet1.SetColumnLabel(0, 3, "4");
                this.fpSpread1_Sheet1.SetColumnLabel(0, 4, "5");



    This looks to be a farpoint spread issue related to scroll positions however I am still unclear on the rootcause of this issue.


    The possible work around I found would be :
     
    1. Making the first two columns visible solves the issue without any changes to UI and the scroll buttons work as expected. 
    2. This issue can also be fixed using the farpoint spread's scrollbar buttons PageUpdown or HomeEnd along with Lineupdown and thumb, however this is will result in changes to UI where the icons for the scroll bar buttons change.



    Can  any of you please let me know if you have encountered such issue.


    Thanks,


    Revathy 



     

  • Replied 8 September 2017, 2:21 pm EST

    Hello Revathy, 

    I am able to replicate this issue.I have reported this as a bug to our QA team. This should be fixed in our next maintenance release of Spread for Windows Forms v5.

    Bug# 99916581

    Thanks,

     

  • Replied 8 September 2017, 2:21 pm EST

    Thanks Deepak. 


    Regards,


    Revathy

  • Replied 8 September 2017, 2:21 pm EST

    Hello,


    The Spread Win v5.0.XX11.2008 maintenance release is now on our website: http://www.clubfarpoint.com/FarPointSupportSite/Modules/Download/updates.aspx


    You an download it from this link:- ftp://ftp.fpoint.com/SpreadWinForms5/


    Thanks.

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels