Problem decimal exceed one million

Posted by: tylor on 8 September 2017, 1:32 pm EST

  • Posted 8 September 2017, 1:32 pm EST

    <p>Hello,</p><p> when I enter number exceeding one million and I leave the cell, the
    space between the thousand and one million is automatically deletes.</p><p>examples : I enter  125 252 555,00</p><p>          after I leave  125252 555,00</p><p><br></p><p> </p><p> <br></p>
  • Replied 8 September 2017, 1:32 pm EST

    <p>Tylor -</p><p>What is the cell type you are using?  It would have to be a GeneralCellType with a NumberFormatInfo structure setting the NumberGroupSizes. <br></p>
  • Replied 8 September 2017, 1:32 pm EST

    The number cell type with max value 999999999999.99<br>
  • Replied 8 September 2017, 1:32 pm EST

    <p>If you are going to stick with the NumberCellType you can try setting the Seperator to an empty string...</p><p>Dim n As New FarPoint.Win.Spread.CellType.NumberCellType<br>n.DecimalPlaces = 2<br>n.Separator = " "<br>n.ShowSeparator = True <br></p>
  • Replied 8 September 2017, 1:32 pm EST

    Same I leave the cell, the separator between the million and the thousand remove<br>
  • Replied 8 September 2017, 1:32 pm EST

    It works in my testing.  Make sure you have the latest maintenance release.<br>
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels