Separator in NumberCellType does not display

Posted by: j2associates on 8 September 2017, 1:26 pm EST

  • Posted 8 September 2017, 1:26 pm EST

    <P>Hello all,</P>
    <P>We have a column which has to be double because of calculations. The resultant calculation is always a whole number so I assigned a NumberCellType to the column as below. I know the cell type is active because the decimals are not being displayed. The problem is that the thousands separator is not displaying. I am using 2001.2005 in VS2005. Thanks in advance for any ideas and/or suggestions!</P>
    <P>                    Dim cellType As New CellType.NumberCellType<BR>                    cellType.DecimalPlaces = 0<BR>                    cellType.Separator = ","<BR>                    column.CellType = cellType</P>
    <P> </P>
  • Replied 8 September 2017, 1:26 pm EST

    <p>j2 -</p><p>Make sure you set the ShowSeparator to True. <br></p>
  • Replied 8 September 2017, 1:26 pm EST

    Thanks, BobM!
  • Replied 8 September 2017, 1:26 pm EST

    <P>Hi All,</P>
    <P> </P>
    <P>i faced Same Problem..Thanks for Advance..</P>
  • Replied 8 September 2017, 1:26 pm EST

    <P>Hello,</P>
    <P>How are you setting up the Cell? If the Spread control is bound to a DataSource, make sure you are setting the DataAutoCellTypes property to False to keep Spread from changing the CellType to default CellType for the data. </P>
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels