Spread hides dialog form

Posted by: johndoe-fp on 8 September 2017, 1:29 pm EST

  • Posted 8 September 2017, 1:29 pm EST

    Hi,


     


    I'm using FarPoint Spread 7.0 with MS Visual Studio 8.0.50727.42 (it seems to be without actual Service Packs) for programming in C#. I create a Form with a button, wich opens a second form with a FarPoint Spread 7.0 control as a Dialog. If I change the application f. e. from my dialog form to Windows Explorer or what else and came back to my application is the dialog form not visible,but the first form. If I minimize the Explorer Window I see my dialog form with the Spread Control.


    If i remove the Spread control from my application is the behavior "normal", so that I not have to minimize the Explorer Window.


    I think this is not the correct behaviour. What to I wrong or how can I change this?


     If somebody needs a example I can create it.


     Thank you

  • Replied 8 September 2017, 1:29 pm EST

    I've tested another situations.

    If the Spread control alone in a Form in works but if there other controls like buttons and radio-buttons in the same form i get the behavior i've described.

  • Replied 8 September 2017, 1:29 pm EST

    I do not see this behavior.  I call ShowDialog on the form with the spread on it, bring up Windows Explorer and go back to my application and the form with spread is still the top form.
  • Replied 8 September 2017, 1:29 pm EST

    Can I send you an email with a example project?

    I think this is a better way as I describe what I've done.

  • Replied 8 September 2017, 1:29 pm EST

    I added four buttons and two radio buttons and I am still not seeing this behavior.  Are you sure your dialog is Modal?  Can you post a small project reproducing this for us to debug.
  • Replied 8 September 2017, 1:29 pm EST

    I've tested my example and real project on two other machines and it works. But I don't know what's the reason.

    For this time it's okay but also strange. 

    I can't test your example project because we didn't have this VS version.

    Thank you for support ;)
     

  • Replied 8 September 2017, 1:29 pm EST

    Here my steps:

    1. Click Button "spread with controls"; The dialog pops up

    2. Change the application f. e. Windows explorer

    3. Change to my application and then I see only "Form1"

    If I minimize my Windows Explorer I see my dialog.
     

  • Replied 8 September 2017, 1:29 pm EST

    Attached is my VB project.  See what behavior you get when you run it.  It is a VS2009 project.  If you don't have that just create a new VB project and copy the forms to it.

    2008/09/ModalSpread7.zip
  • Replied 8 September 2017, 1:29 pm EST

    In my project I do not see this behavior.  In your project I do see it but it happens for both of the other forms not just the one with other controls on it.  I have no idea why.  I would suggest researching whether there are some IDE settings for other forms in a C# project and how to make them modal.  My project is in VB and it works as expected.
  • Replied 8 September 2017, 1:29 pm EST

    Just attach your project to the post.  There is an Options tab at the top of the page when you reply that allows you to attach a file.  Just zip up the project and attach.  Make sure it is less than 256K.
  • Replied 8 September 2017, 1:29 pm EST

    Oh yeah I found this option. It's a little tricky to find it ;)

     


    2008/09/spread issue.zip
  • Replied 8 September 2017, 1:29 pm EST

    I ran your project and I still do not see the issue.  Are there any other steps I need to take?
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels