Strange behavior in 4.0.2009.2005 version

Posted by: kozu on 8 September 2017, 1:45 pm EST

  • Posted 8 September 2017, 1:45 pm EST

    Hi,

    I've just installed spwin4_net20-2009 and I noticed something extremely strange. Whenever I click on the spread's header, the rows shift. The underlying DataSource is unchanged, but in the UI the rows shift down by 1.

    I haven't changed any code and I went back to the previous version I had installed (4.0.2003.2005) and it works fine.

    I can try to come up with a sample project, but I wanted to check if this is a know issue. The shift does not happen when I double-click a cell, if it makes any difference.

     thanx

  • Replied 8 September 2017, 1:45 pm EST

    Hello,

    I have tried replicating the said behavior with the same build as mentioned by you by clicking on the column header, row header and they select the entire column and row respectively. I have also tried clicking on the left-top most cell of the control and it selects the entire sheet, which is the default behavior of the control. Hence, we request you to please post a sample project, which replicates the reported behavior at our side.

     

    Regards,

    Suresh

  • Replied 8 September 2017, 1:45 pm EST

    Hi,

    Here's a code snippet:

    //setup a dataSet

    DataSet ds = new DataSet();

    DataTable tbl = new DataTable();
    tbl.Columns.Add(new DataColumn("Name", typeof(string)));
    tbl.Columns.Add(new DataColumn("ID", typeof(int)));

    ds.Tables.Add(tbl);

    DataRow row = tbl.NewRow();
    row["Name"] = "aaa";
    row["ID"] = 100;
    tbl.Rows.Add(row);

    row = tbl.NewRow();
    row["Name"] = "bbb";
    row["ID"] = 200;
    tbl.Rows.Add(row);

     

    //set the grid's dataSource

    fpSpread1.ActiveSheet.DataSource = ds;

     

    //add a comboBox header 

    fpSpread1_Sheet1.Rows.Add(0, 1);
    FarPoint.Win.Spread.CellType.ComboBoxCellType cmb = new FarPoint.Win.Spread.CellType.ComboBoxCellType();
    cmb.Items = new string[] {"ccc", "123"};
    fpSpread1_Sheet1.Cells[0, 0].CellType = cmb;

     

    //set the header's value

    fpSpread1_Sheet1.Cells[0, 0].Value = "ccc";


    Now:

    - click on the 'aaa' cell

    - select the 'ccc' column

    - click back on the 'aaa' cell

    The first row becomes empty, and ccc shows up between 'aaa' and 'bbb'

  • Replied 8 September 2017, 1:45 pm EST

    Hello,


    I was able to reproduce this issue and have reported this as a bug (#24775) for the development team to fix for the next maintenance release. For now, you can use the AddUnboundRows method to add the new row to workaround the issue.

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels