Unable to Copy and Paste Using CTRL-C / CTRL-V

Posted by: allenk on 8 September 2017, 2:23 pm EST

  • Posted 8 September 2017, 2:23 pm EST

    Hi,


    I am having trouble using the standard windows copy and past functions in the a windows app.  I have the same problem in VS 2008, 2010, and on Vista and Windows 7


    CTRL-INS and Shift-INS work.


    The spread version is 4.0.3505.2008


     I have set Autoclipboard to true and don't have any code that intercepts keys.


     Anyone else having this problem?


    Regards,


     


    Allen

  • Replied 8 September 2017, 2:23 pm EST

    Hello Allen,


    Unfortunately I am unable to replicate the issue at our end using the same version you have mentioned and using the shortcut keys i am able to copy paste the cell contents in Spread.


    Please make sure that you are not trying to paste incompatible DataTypes into each other( For ex.-  TextCellType values in NumberCellType or DateTimeCellType) as their DataType are not compatible and it will then paste blank values.


    Please have a look at the attached sample wherein copy paste using shortcut keys works well but incase we are trying to copy TextCellType (Column1) value in NumberCellType (Column2), then it will paste blank values.


    Please have a look at the same and also let us know the steps to replicate the issue at our end.


    Thanks.


    2010/07/CopyPaste.zip
  • Replied 8 September 2017, 2:23 pm EST

    Thank you for your response.  I would agree with your comments about pasting one cell to another however I am simply trying to copy from the spread and paste into another application.  The data does not appear to be in the clipboard using ctrl-c.


    Regards,


    Allen

  • Replied 8 September 2017, 2:23 pm EST

    Hello,

    Unfortunately we are unable to replicate the issue as on copy pasting the values using Ctrl+C and Ctrl+V from Spread cells in other application( like Excel, word and notepad) works well at my end, as well as copy pasting from other application to Spread works well too.

    Please have a look at the video depicting the similar behavior and also let us know on which application you are trying to paste the clipboard copied values? And please make sure you haven't set AutoClipboard property of the Spread to false.

    If possible please send us the sample replicating the issue for us to debug at our end.

    Here is the link for the video:- ftp://ftp.fpoint.com/ActiveReports/Samples/CopyPaste.rar

    Thanks.

     

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels