Unable to render (Low Memory) Error Again

Posted by: lg_sony_27 on 8 September 2017, 2:23 pm EST

  • Posted 8 September 2017, 2:23 pm EST

    Hi! I am again stuck with this error. I have a previous problem with this here and here. I was able to solved it...but now, I am using vs2010 and windows vista in my computer (home computer) which obviously uses .netframework 4. There are a lot of columns hidden from my spread and at least 17 tab sheets are present. The error occur when I click on the other tabs and then type in values and presses the enter key. I have codes like


    With FpSpread1.Sheets(0)


    num.DecimalPlaces = 0


    .DataAutoCellTypes = False


    .Columns(12, 82).CellType = num


    .Columns(84, 86).CellType = num


    .Columns(88, 90).CellType = num


    .Columns(92, 94).CellType = num


    .Columns(96, 98).CellType = num


    .Columns(100, 102).CellType = num


    .Columns(104, 106).CellType = num


    .Columns(109).CellType = num


    End With


    I will do the following:


    1. I will be copying the app in windows xp sp2 (office computer) and install vs2010 so .netframework 4 will be installed automatically.


    2. I will copy bin folder in the workstations which uses windows xp sp2 which uses .netframework 2.0.


    questions:


    1. why can't the spread work on .netframework 2.0 SP2 and beyond? What should I do to solved this problem?


    2. Is it ok to install Spread for Windows Forms for 3.5 Framework 4 windows xp sp2? If yes, do I need to install .netframework 3.5 or 4?





     

  • Replied 8 September 2017, 2:23 pm EST

    Hi!


    I fresh installed windows 7, visual studio 2010, Spread for Windows Forms for 2.0 Framework 4 (4.00.2022), and using .NET Framework 4.0.30319. I still get the same error.


    I converted my app from vs2005 (which is running okay) using .Net Framework 2.0 version 2.0.50727.42 and Spread for Windows Forms for 2.0 v 4.00.2022 to vs2010. I dont get any error whenever I enter values from any columns in the first tab sheet....but wheneve I enter data in the adder tab sheets (2nd and so on..) i get the error --this scenario was the same in vs2005 app until I upgraded my framework to version 2.0.50727.42.


    Part my codes are found in this thread and more detailed posting regarding the used of .net framework versions.


    As I mentioned earlier I have a lot of columns hidden.


    For example: I have 500 columns


    tab sheet 1 - columns 1-4, 11-100 are shown, the rest are hidden


    tab sheet 2 - columns 1-4, 101-200 are shown, the rest are hidden


    tab sheet 3 - columns 1-4, 201-300 are shown, the rest are hidden


    tab sheet 4 - columns 1-4, 301-400 are shown, the rest are hidden


    tab sheet 5 - columns 1-4, 401-500 are shown, the rest are hidden


     

  • Replied 8 September 2017, 2:23 pm EST

    Hello,


    1) Spread work on .Net Framework 2.0 SP2 and beyond but please make sure you have the latest version of .Net framework 2.0 ( which has been specified in your earlier reference thread i.e. .Net Framework 2.0 version 2.0.50727.42)


    2) Yes, it is ok to install Spread for Windows Forms for 3.5 Framework on Windows xp sp2 having .Net Farmework 4 installed (as its the latest Frmework and is compatible with Framework 3.5 as well).


    If that does not help, then could you kindly provide me a small sample application replicating the issue you are facing so that we may have a better picture of the issue which you are encountering at the moment?


    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    Hello,


    Unfortunately, we are unable to replicate your issue with the Spread and Framework specification you have mentioned. Could you please provide us with a sample replicating the issue or the video showing the problem you are facing at the moment, so that we may look into the issue and provide you with a solution.


    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    Hello,

    We are unable to replicate the issue at my end using the sample you have provided us with as the database is missing. You can upload your database here at:- ftp://ftp.fpoint.com/ActiveReports/upload/ for us to proceed further.

    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    here's my test application...sheet one will work when entering records but sheet2 will give me the error.

    Steps:
    1. select section
    2. select subject
    3. click display
    4. select sheet2
    5. enter records
    2010/08/TestApp1.zip
  • Replied 8 September 2017, 2:23 pm EST

    Hi!


    Where will I send a test proj? Im afraid I cant send the database file..it's 428MB. I dont have recorder so i cant send you a video.

  • Replied 8 September 2017, 2:23 pm EST

    My app is large as well its database so I will try to make a video showing how the error occurs.


    thanks.

  • Replied 8 September 2017, 2:23 pm EST

    I tried again installing vs2010 and Spread for Windows Forms 3.5.3522 in windows xp sp2, I have .NET Framework 4.0.30319 also but then again the same error occurs...very frustrating scenario.
  • Replied 8 September 2017, 2:23 pm EST

    i can't login to your ftp site....I managed to trimmed down the size of the database to 3MB but only 256 kb is allowed as attachment.


    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    Additional info....When I run the same program in vb 2005 under windows xp with .net framework 2.0.50727.42 it is working fine but once i updated the .net framework to sp2 and up, i get the same error. Is it a bug?


    Hoping to hear from the any of the admins on how to solve this one...


     


    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    any feedback?
  • Replied 8 September 2017, 2:23 pm EST

    hi!


    I think i already uploaded it successfully....please check it. the filename is TESTDB.ZIP....I'll wait for any result from you, i am really eager to know the reasons why i am getting such error. I'll be online for a long time today.


    Hoping to hear from you soon.


    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    Hi!


    how do i upload it? i am not seeing any upload utility to use.

  • Replied 8 September 2017, 2:23 pm EST

    Hello,

    You need to login as anonymous user and then upload your database there.

    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    Hello,

    Unfortunately we are unable to replicate the issue at our end with the sample you have provided. It is running successfully without any error. Here is my system's configuration:-

    1) Microsoft Visual Studio 2010
       Version 10.0.30319.1
       Microsoft .NET Framework
       Version 4.0.30319

    2) Microsoft Windows 7 Ultimate OS

    3) Using Spread for Win Forms version 4.0.3522.2008.

    Please let us know your system's configuration in order to find a solution to your problem as your sample is running perfectly fine at my end. Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    I dont have the unit here right now, I'll just give some that I can remember. I will post here the full detail of my system's configuration later.


    1. Microsoft Visual Studio 2010
        Version 10.0.30319
        Microsoft .Net Framework
        Version 4.0.30319


    2.  Microsoft Windows 7 Ultimate OS


    3. I tried using Spread for Win Forms Version 5.0.3511.2008


    Noticed, that this program only works winxp with specs mentioned in post #3.
    I am able to use any version of the spread for .Net Framework 2.0 as long as I use .Net Framework 2.0 version 2.0.50727.42. Any attempt to use any version of the spread with the latest .Net Framework proved to be not working....Again, the error can be seen only when I type values/records to tab sheet 2 and onwards, typing records in tab sheet 1 will not produce any error at all.


    I have used different computers with different OS's (winxp and win7), different spread versions and .Net Framework versions and it's frustrating that I get the same problem.  I am not able to upgrade my Framework and can only use winxp if this will remain to be case.


    Right now, I am looking for a good screen capture so that I can show you how this problem occurs, can you suggest any?


    Hoping that this problem will be over soon....

  • Replied 8 September 2017, 2:23 pm EST

    Hi!


    I tried installing VS2010 on winxp sp3 I get the same problem. Here's my system's configuration.


    1. Microsoft Visual Studio 2010
        Version 10.0.30319
        Microsoft .Net Framework
        Version 4.0.30319


    2.  Microsoft Windows XP SP3 OS


    3. I tried using Spread for Win Forms Version 5.0.2011.2008

  • Replied 8 September 2017, 2:23 pm EST

    Hello,

    It seems to be working fine with Windows 7. We will test this with Windows XP and will inform you about our observation.

     

     

    Thanks,

     

  • Replied 8 September 2017, 2:23 pm EST

    I have Win 7, VS2008, spread version 5.0.2003.2008, runtime version v2.0.50727. 


    I get this problem when I try to preview the spread control.  But if I comment out 2 lines of code, the problem is gone.  Here is the code lines: 


    Using Header2 As New Font("Verdana", 9, FontStyle.Bold)


    'spreadSheet.Rows(2).Font = Header2 '<-Make memory problemer


    'spreadSheet.Rows(HeaderRow).Font = Header2 '<-Make memory problemer


    End Using


    I hope this information can help you solving the problem.

  • Replied 8 September 2017, 2:23 pm EST

    Thanks for the reply. I dont have a code like that or similar to that.
  • Replied 8 September 2017, 2:23 pm EST

    I uploaded a videos showing the error...Please tell me if you are receiving my uploads...(testapp1.zip, testdb.zip and videos.zip)


    Here's my system's configuration:


    1. Microsoft Visual Studio 2010
        Version 10.0.30319
        Microsoft .Net Framework
        Version 4.0.30319


    2.  Microsoft Windows 7 Ultimate OS


    3. I tried using Spread for Win Forms Version 5.0.3511.2008

  • Replied 8 September 2017, 2:23 pm EST

    Hello,

    We are able to replicate the issue finally at our end by entering values in Tab2 rapidly as shown in your video. It could be possible that it could be a bug in latest framework as it was working fine with the old framework release. However, we have reported it as a bug in Spread version 4.0.3522.2008 and version 5.0.2011.2008 as well and the bug number for the same is #99917823.

    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    Hello,


    No worries. Take your time. I think it's another.


    I'll just wait for your update and hopefully the bug will be fixed soon. Thanks.


     

  • Replied 8 September 2017, 2:23 pm EST

    Hello,

    I am unable to replicate the issue at my end using the sample provided wherein I have added another sheet in Spread and on moving back and forth on the tabs I am not seeing any duplicate records neither the values are being repeated. I tested it in Windows 7 O.S and with Spread version 4.0.3522.2008.

    Please have a look at the Sample uploaded here ftp://ftp.fpoint.com/Samples/TestApp1.zip and let us know the steps to replicate it and if possible please make a video of the same and revert back.

    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    Hello,

    We release maintenance builds every 3 months and next build is scheduled for the month of October and we have already reported your issue with high priority and hopefully it will be fixed in the next maintenance release.

    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    Hi!


     I have been very busy for a while that's why I wasn't able to create a video on the 2nd issue I raised. I will try to create a video of it as soon as i can find time.  Anyway, when will be the target release of your new update? I hope the problem I encountered is already resolved when you release your update.


    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    I a looking forward to it and hoping that comes October, the issue raised is already fixed. Please do kindly take a look at the other I mentioned in my previous post.


     Thanks!

  • Replied 8 September 2017, 2:23 pm EST

    Hello,


    Apologies for the delayed response. I tested your second issue on Win7 and I still need to test it on a different OS ( Win XP) and also with Spread version 4.0.3522.2008 and version 5.0.2011.2008. I just want to make sure that whether I can update the existing bug with this issue or do i need to report a separate bug for the same.


    I just need some more time. Will update you soon with my observations. Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    Hi!


    I'm glad finally that you are able to proved my claimed. Please also take note that another thing i have found is when I clicked on the tabs back and forth especially when there are more tabs, the names and records will sometimes disappear or sometimes will display duplicate records.


    By the way, I encountered this problem long before with Spread version 4.2003.2005 and other releases, it's not only in the latest version that's why I didn't upgrade to vs2008 or vs2010 as these uses .Net Framework 3.5. and 4.0. Please refer to post#1 for the link of my other threads with similar topic. The releases will only work with .Net Framework 2.0 version 2.0.50727.42 using win xp.


    I hope you don't mind me asking...When would be the possible target of maintenance release addressing the issue?


    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    Hello,

    Is your system Configuration still same:-

    1. Microsoft Visual Studio 2010
        Version 10.0.30319
        Microsoft .Net Framework
        Version 4.0.30319

    2.  Microsoft Windows XP SP3 OS/ Windows 7 Ultimate

    3. Spread for Win Forms Version 5.0.2014.2008

    Let me know in order to investigate this issue further.

    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    Hello,

    We have verified your issue, it has been fixed with our upcoming build. Will release the build soon.

    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    No updates yet?
  • Replied 8 September 2017, 2:23 pm EST

    Hello,

    We will be releasing the maintenance build soon, somewhere in end of October. Work is already going on in fixing your issue, our developers is working on the same and hopefully it will be fixed in the upcoming build. Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    it's good to hear that....I am very excited to upgrade from vb2005 to vb2010...looking forward to it.


     Thanks!

  • Replied 8 September 2017, 2:23 pm EST

    here's my configuration now...


    1. Microsoft Visual Studio 2010
        Version 10.0.30319
        Microsoft .Net Framework
        Version 4.0.30319


    2.  Microsoft Windows XP SP3 OS/ Windows 7 Pro


    3. Spread for Win Forms Version 5.0.2014.2008


     


    by the way when i viewed the fixes, the bug number #99917823 is not included there.

  • Replied 8 September 2017, 2:23 pm EST

    Hi!


     I have downloaded your latest update and tried it at once...I think my issue has not been fixed totally although I am getting the error when I enter values using the second tab but further testing it resulted with the same problem...I'll be doing a sample video of it later but to give you an idea, I tried copying the records in the first tab, paste it in the second, third and fourth tabs...The error displayed in the fourth tab...


    Hoping that the initial info. i have here will help fixing the problem.


    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    Hello,

    I verified this issue earlier and it was not replicable at my end. I don't know what went wrong now that it is being replicated again. I have escalated your issue again to our Project Development Team for further investigation on the same using your system configuration. There response is awaited, will update you soon with further observations. Sorry for the inconvenience.

    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    Hello,

    It seems to be an intermittent issue because our developers are not able to replicate the issue at their end and moreover it wasn't replicable at my end earlier with the latest maintenance release.

    Our
    understanding is that the problem occurs when entering values into the
    cells in the bound columns, by typing the value and pressing Enter, or
    by using drag-fill as shown in your video sent earlier.

    I would request you to please send us the video replicating the same as a
    new video will help us because it seems that steps might have changed.

    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    I really plan to make a video so that once and for all this issue will be solved.
  • Replied 8 September 2017, 2:23 pm EST

    Hello,

    I have reopened your case and will investigate more on the same and let you know the updates. 

    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    Hi!


    I noticed that the bug number #99917823 is already fixed in your latest released 05.00.2014 so I downloaded and installed it.  I tried clicking my 2nd sheet and then typed a value and it went okay but i tried further clicking the 3rd sheet and then the 4th sheet---the same problem still now appears.  I re-run the program and then I just clicked on the 2nd sheet, 3rd and 4th sheets (this time without typing any value) the error still appears. I further tested the new released...I entered a value and the tried to click my save button and i closed and re-open the program to my surprise the value I typed was not saved.


    With this problem I reverted back to 05.00.2011.


     My system's configuration:


    1. Microsoft Visual Studio 2010
        Version 10.0.30319
        Microsoft .Net Framework
        Version 4.0.30319


    2.  Microsoft Windows 7 Professional OS


    Note: I also tried using Microsoft Visual Studio 2005

  • Replied 8 September 2017, 2:23 pm EST

    Hi!


    Thanks for the immediate action and no worries.. Smile

  • Replied 8 September 2017, 2:23 pm EST

    Hello,

    According to our team this bug has been marked as fixed as it is not reproducible at our end now. It could be very helpful if you can send us the build output content.The steps are following:

    1.       Build the project.

    2.       Copy the “Output” content in the “Output” window.

    3.       Send the content back to us to analyze with the exception details.

     Hopefully, with these information we could fix it once and for all. Sorry for the inconveniences.

  • Replied 8 September 2017, 2:23 pm EST

    Hello,





    Our latest maintenance build is out yesterday. You can test it with the latest build as it has been fixed. You can get the latest build from this link 


    ftp://ftp.fpoint.com/SpreadWinForms5/

    Thanks.

  • Replied 8 September 2017, 2:23 pm EST

    hi!

    Do we have an update on the issue?
  • Replied 8 September 2017, 2:23 pm EST

    Hello,

    I would like you to know that your query has been answered at the following forum post that discusses the similar issue:

                 http://www.clubfarpoint.com/Forums/forums/thread/107534.aspx

    Hope it will help you. Please let me know if you have any queries further.

    Thanks,

    Manpreet Kaur

  • Replied 8 September 2017, 2:23 pm EST

    up until now i can't run my app in windows 7 due to this issue...
  • Replied 8 September 2017, 2:23 pm EST

    Hello,

    Along with the above that Reeva asked for, we also need a complete sample project where you have 4 sheets in spread. This case is under investigation and we are trying to fix it for you. Your co-operation is highly appreciated.

     

    Thanks,

     

     

  • Replied 8 September 2017, 2:23 pm EST

    Hi!


    I have just finished trying out your latest build with my project but still the problem exist as i have mentioned in my post dated 01-09-2011...


    thanks!

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels