Upgrading redistributable (client version) to 4.0.3510.2008

Posted by: snowhiterw on 8 September 2017, 1:51 pm EST

  • Posted 8 September 2017, 1:51 pm EST

    I followed the directons for upgrading Spread for Windows Forms (.Net) on my development machine.  The misc properties of the spread control in my form now shows the new version and when I build my program it is clearly running the new Spread version because bugs that were fixed in that release have gone away.  When I transfer the .exe and the Spread .dlls (placed in the same dir as the .exe) to a "vanilla" computer I get the following runtime error when the program tries to load the form with the spreadsheet control on it: ( it is clearly trying to find the old version).

    System.IO.FileLoadException: Could not load file or assembly 'FarPoint.Win.Spread, Version=4.0.2009.2005, Culture=neutral, PublicKeyToken=327c3516b1b18457' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)<o:p></o:p>

    File name: 'FarPoint.Win.Spread, Version=4.0.2009.2005, Culture=neutral, PublicKeyToken=327c3516b1b18457'<o:p></o:p>

       at AutoCabinetReports.AutoCabinets..ctor(MainForm parent, String csReport, String csFilename)<o:p></o:p>

       at AutoCabinetReports.MainForm.MainForm_Load(Object sender, EventArgs e)<o:p></o:p>

       at System.Windows.Forms.Form.OnLoad(EventArgs e)<o:p></o:p>

       at System.Windows.Forms.Form.OnCreateControl()<o:p></o:p>

       at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)<o:p></o:p>

       at System.Windows.Forms.Control.CreateControl()<o:p></o:p>

       at System.Windows.Forms.Control.WmShowWindow(Message& m)<o:p></o:p>

       at System.Windows.Forms.Control.WndProc(Message& m)<o:p></o:p>

       at System.Windows.Forms.ScrollableControl.WndProc(Message& m)<o:p></o:p>

       at System.Windows.Forms.ContainerControl.WndProc(Message& m)<o:p></o:p>

       at System.Windows.Forms.Form.WmShowWindow(Message& m)<o:p></o:p>

       at System.Windows.Forms.Form.WndProc(Message& m)<o:p></o:p>

       at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)<o:p></o:p>

       at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)<o:p></o:p>

       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

    WRN: Assembly binding logging is turned OFF.<o:p></o:p>

    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.<o:p></o:p>

    Note: There is some performance penalty associated with assembly bind failure logging.<o:p></o:p>

    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].<o:p></o:p>

    <o:p> </o:p>

  • Replied 8 September 2017, 1:51 pm EST


    It seems that your application is trying to access the Spread dlls from location other than the bin directory of your application. Please try following below listed steps in your development machine.

    1. Open your project in Visual Studio.

    2. Open Solution Explorer 

    3. Under References folder select the <span class="Apple-style-span" style="font-family:Tahoma;">FarPoint.Win.Spread.dll file. </span>

    4. Right click on it and select "Properties".

    5. Set the "Copy Local" property to true.

    This will ensure that the dll being used by the application is copied to the bin directory of your application. You may then copy the entire Bin/Debug or Bin/Release folder of your application to <span class="Apple-style-span" style="font-family:Tahoma;">"vanilla" computer and then try to run the exe file . </span>

    I hope it helps.


  • Replied 8 September 2017, 1:51 pm EST

    this is what I did to fix it:

    <DIV>Control Panel - Add Remove Programs - removed old version of FarPoint Spread.</DIV>
    <DIV>C:Windows\Assembly - right clicked on each of the .dlls for the old version, then clicked UnInstall.</DIV>
    <DIV>In Visual Studio .net under References in my project I selected all of the FarPoint references, right clicked then selected "Properties".</DIV>
    <DIV>I changed "Specific Version" from "True" to "False".</DIV>
    <DIV>I rebuilt the project solution in Visual Studio.</DIV>
    <DIV>copied the new .exe to the "vanilla" computer that contained the new .dlls only.</DIV>
    <DIV> </DIV>
    <DIV> </DIV>
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels