version 4 - export to Excel

Posted by: stage on 8 September 2017, 1:01 pm EST

  • Posted 8 September 2017, 1:01 pm EST

    When I use the SaveCustomColumnHeaders flag and I have notes in the cells, the exported Excel file will have the notes (comments in Excel) in the incorrect row. For example if the note is in cell A1 and I am using 2 rows in the header, then the cell A3 should have the comment but it will still be in cell A1.


    Also, in previous versions the comments were in the same visible state as the Spread. In the Spread the user needs to place their mouse over the note indicator. However in the Excel file all the comments are displayed by default. I cannot find a setting to turn this off.

  • Replied 8 September 2017, 1:01 pm EST

    I wrote the "note in the header after exporting" as bug 22033.  For the second question, what code did you use to turn off the cell note in Spread?
  • Replied 8 September 2017, 1:01 pm EST

    I am also experiencing notes appearing in exported Excel spread sheets.  One question that wasn't answered from earlier was is there a way to set a flag or something to turn the notes off when doing a Grid.SaveExcel?  Or in other words, is there a workaround until the bug is fixed?
  • Replied 8 September 2017, 1:01 pm EST

    Hello,


    You should be able to set the DataOnly flag to keep Notes from being exported to Excel. You can also remove the Note from each of the cells in Spread before the export to Excel.

  • Replied 8 September 2017, 1:01 pm EST

    The Spread for Windows Forms 4 patch is now on our web site.
    http://www.clubfarpoint.com/FarPointSupportSite/Modules/Download/updates.aspx
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels