While Saving SpreadSheet Data Creates a New Column

Posted by: tejashvini on 8 September 2017, 1:53 pm EST

  • Posted 8 September 2017, 1:53 pm EST

    Hi,


    I have a farpoint SpreadSheet on my Windows form. I have a button to add an empty row (btnAddRow). And I have a button to save (btnSave) changes to database. When I enter some data and Click on Save button a New Row is added to the SpreadSheet. There is no code in the btnSave_Click event. Still it adds to the Spread. If the data entered in the new row is valid, the new valid record is added to the database and the spread is refreshed. But if I enter some invalid data the Recrods are not saved and throws a custm error message that we have in our code. Once we click ok on the message we are on the Spread which is not refrshed. Hence we have the invalid row and the blank new row which is added automaticaly when I click the save button. Please help why this new balmk row is added.

  • Replied 8 September 2017, 1:53 pm EST

     


    Hello,


    I am not able to replicate the issue , could you please send us a small zipped project.


    Thanks,


    Deepak Sharma

  • Replied 8 September 2017, 1:53 pm EST

    Hi Deepak - I'm using Farpoint SPread 4.0. I dont see an option to attach the zip project?

  • Replied 8 September 2017, 1:53 pm EST

    Hello,

    I could not run your sample code, however I tried adding the blank row and row with data using the AddUnboundrows and AddRowToDataSource and it did not add any additional row to the Spread control.I would request you to please send across a zipped sample project for us to debug. You can add the zipped file using the option tab file composing your message.

    Thanks

  • Replied 8 September 2017, 1:53 pm EST

    You may have to change the query to something in your DB
    2009/05/WindowsApplication1.zip
  • Replied 8 September 2017, 1:53 pm EST

    Hello,


    I tested your project with my own data and was not able to reproduce the issue. Could you let me know the steps to reproduce the issue. Also, your project is not using the latest maintenance release of Spread for Windows Forms. Try getting the latest release (version 4.0.2010) to see if this works correctly.

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels