Spread for ASP. Net 4 can not show the icons in the toolbar

Posted by: vazquja on 10 September 2017, 10:58 am EST

  • Posted 10 September 2017, 10:58 am EST

    I deploy a program in my IIS Server but the spread can't show the icons in the toolbar. I have the same program with a previous version of Spread and is working ok. The server already has framework 2.0 and the fp_client directory with the repective HTC files for both version. I already follow the instruction to do the redistribution but I continue with the same problem. What can I do to fix it?


     


     


     


    Regards,


    Jose

  • Replied 10 September 2017, 10:58 am EST

    Jose,

    It certainly looks an issue with the deployment. I would request you to please make sure that you are using the correct version of Spread under fp_client folder. It should be as same as you have used in your website. Also make settings in web.config so that it can find the fp_client folder easily. For example if you place fp_client folder in the web application directory. The following code would need to be added to the web config file. For example:

    <?xml version="1.0"?>

    <configuration>

    <system.web>

        ...

    </system.web>

    <appSettings>

    <add key="fp_client" value="fp_client" />

    </appSettings>

    </configuration>

    Be aware that Spread ASP.NET creates a Web server control that serves up HTML pages for clients and it also puts HTC files in a directory on the client machine for client-side scripting capability.


    Thanks,

  • Replied 10 September 2017, 10:58 am EST

    I already have all that instructions in my web.config but the problem continue The fp_client is into wwwroot directory. This is the link \\lapprsrv06\c$\Inetpub\wwwroot\fp_client\fpspread. Into the fpspread I have the following directories 2_0_2_0, 2_5_2013_2005,4_0_2025_2008,4_0_3525_2008. I not have idea what else can I do. Like I said older versions in the same IIS are working.
  • Replied 10 September 2017, 10:58 am EST

    Hello,

    I would suggest you to place fp_client folder in application's root directory instead of wwwroot directly with above settings and let me know if the issue still persists.

     

    Thanks,

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels