banding some columns-GridView

Originally Posted 21 February 2016, 8:25 am EST

  • Originally Posted 21 February 2016, 8:25 am EST

    Hi all
    I have a problem with banding columns. So I'm not sure about the way, but I create some bands (C1Band) and put some c1BoundField in each band.
    I want to have a C1Gridview Like the picture below.
    But my GridView just know C1Band(s) for columns. It means if I put 3 C1Band(s) and put 3 c1BoundField(s) for each C1Band, C1GridView1.Columns.count=3 (but actually I want to have 9 columns)
    What must to do?
    what's the problem?
    Could anyone help me please?

  • Reply

    Hello,

    There may be some implementation issues exist at your end. Could you please share a stripped down sample replicating the issue so that I can debug the exact issue and can assist you accordingly.

    Regards,
    Prashant
  • Reply

    Hello
    Thanks a lot for your reply Mr Prashant
    I did it, but still it dosen't work :(
    I found when I define columns and then define a dataSource for grid, it dosen't work!
    I mean, It didn't show rows, but Rows.count are correct!
    And so, table shows Columns correctly, but says wrong Columns.count!!!

    Thanks for any help
  • Reply

    Hello,

    In order to create a multi level column header with C1GridView, I suggest you to please refer to the below demo link:

    http://demo.componentone.com/aspnet/ControlExplorer/C1GridView/Bands.aspx

    Also, please find the attached sample implementing your scenario and let me know in case of any doubts or queries.

    Regards,
    Prashant
    2016/02/WebApplication2.zip
  • Reply

    Hello
    I did it, but I haven't you email address!
    sorry
  • Reply

    I found another problem now!
    I did it:
    C1GridView1.ControlStyle.BackColor = Color.Blue;
    C1GridView1.HeaderStyle.BackColor = Color.GreenYellow;

    When I run the page, Colors show just for a second and then it change to default(To default color as selected theme)
  • Reply

    It's a screen picture of my project(after run)

  • Reply

    Hello,

    This web site is seems to be blocked in our region. You are requested to please share your sample on our FTP server.
    Here are the FTP instructions:
    1. Open Internet Explorer
    2. Go to ftp://ftp.componentone.com/SupportFTP/Public/
    3. Click Alt and then select View > Open FTP Site in File Explorer
    4. In the resulting window, right-click the whitespace in the main pane and select Login As from the popup menu
    5. Enter the following credentials:
    Username: Supportftp
    Password: 123ceftp123
    6. Copy your project zip file to the a any folder(New or Existing)
    7. Email me and let me know when it finished copying

    Regards,
    Prashant
  • Reply

    Hello,

    I could not find any sample in on ftp server with the name "WebSite2.zip". Could you please re-upload the sample and copy the url from the address bar and share it here? So that I can find the uploaded sample.
    Note: Please very the upload by closing the window and opening the same window after upload.

    Regards,
    Prashant
  • Reply

    Hello,

    Can you please provide me the name of your sample or the link where you have copied?

    Regards,
    Prashant
  • Reply

    After I entered username and password, a window opened, I put it exactly on that window
    Name of file is WebSite2.zip
  • Reply

    Hello
    Thanks for your reply again :)
    Here is link of my project

    http://uploadboy.me/u9wvwkf6ue2o/WebSite2.rar

    (It was up to 3MB and I uploaded it for you)

    Thanks for your help
  • Marked as Answer

    Reply

    I finely could to fine my problem :)
    I solved it :D
  • Reply

    Really nobody can help me? :(
  • Reply

    I did it :)
    It's the link:
    ftp://ftp.componentone.com/SupportFTP/public/Sara%20T/
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels