Combobox not working properly when inside a hidden element

Posted by: wwalker on 10 September 2017, 11:44 am EST

  • Posted 10 September 2017, 11:44 am EST

    This seems to be a common problem among combobox's rendered inside a hidden element. I have had this same issue with four other combobox's that I've tried to use. Also one that Peter Blum has fixed on of AJAX control toolkit.

    So the problem is, I have a div that is basically functions like a modal popup (via jQuery). So basically the content is hidden on page load. So, when the page renders, the combobox doesn't know the correct width and height based on the DOM. Do you guys have a workaround for this?
  • Replied 10 September 2017, 11:44 am EST

    Hello,

    Sorry for the delay in response. I was able to replicate the issue. I have escalated it to the concerned team, I will update you as soon as we get any update on this.

    Regards
    Nidhi
  • Replied 10 September 2017, 11:44 am EST

    Hello,

    According to the developer, this issue is a limitation in C1Wijmo control. Our developer have provided a workaround for this issue.
    Please find the attached sample "Sample_C1ComboBoxInsideHiddenElement_workaround" which is provided by the developer.
    Could you please download it and check it at your end.

    Hope it resolved your problem..!!
    Regards
    Nidhi
    2012/08/Sample_C1ComboBoxInsideHiddenElement_w.zip
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels