DatePicker Culture

Posted by: blitzsr on 10 September 2017, 11:43 am EST

  • Posted 10 September 2017, 11:43 am EST

    Hi! I can not set the culture for the DatePicker control. Strange that this does not occur when using the Calendar control. And when I tried to use DatePickerExtender , this error was displayed:

    'this.inputWidget._getCulture (). calendars' is null or not an object.

    Why does not obey the control option of Culture as the Calendar?



    .aspx Code:


    -------------------------------------------------------------------------------------------------
    .cs Code:

    this.C1InputDate1.Culture = new System.Globalization.CultureInfo("pt-BR");



    Thanks!
  • Replied 10 September 2017, 11:43 am EST

    Ok, im waiting.

    Thanks!
  • Replied 10 September 2017, 11:43 am EST

    Hello,

    It seems that there is some issue with InputDate Extender and I have escalated this issue to the developer for review. I would update you as soon as I hear anything from them.

    Regards
    Ashish
  • Replied 10 September 2017, 11:43 am EST

    Hello,

    I would like to inform you that the issue has been fixed in the latest build but currently, it is being tested by QA. The build will be available on the pre-release site as soon as it is cleared by the QA.

    Regarding the Live demos, could you kindly let me know which demo is not working and on which browser so that I can check the same at my end ?

    Regards
    Ashish
  • Replied 10 September 2017, 11:43 am EST

    Hi! Anything new? Another thing ... Live Demos is not working.

    Thanks.
  • Replied 10 September 2017, 11:43 am EST

    Hello,

    I would like to inform you that Wijmo controls are HTML5 based controls and they are not compatible with Firefox 4 since it does not support HTML5.

    Therefore, I would suggest you to upgrade your FireFox to latest version and you may download the same from the following link:
    http://www.getfirefox.net/

    Regards
    Ashish
  • Replied 10 September 2017, 11:43 am EST

    Hello,

    I understand the issue but unfortunately, it is working fine at our end in english environment. I am not sure but it may be an environment specific issue so could you kindly provide me details of same like Operating system etc. This would help me in finding the cause and providing an appropriate solution for same at the earliest.

    Regards
    Ashish
  • Replied 10 September 2017, 11:43 am EST

    Hi! I am using IE8 and Chrome 16. Both have the same error. I can not see the controls working. This is happening since the end of last year. Was there any update?

    These (http://demo.componentone.com/ASPNET/MVCExplorer/) work well!

    These (http://demo.componentone.com/ASPNET/ControlExplorer/) do not work.

    error:
    Message: Object does not support this property or method
    Line: 17
    Char: 2
    Code: 0
    URI: http://demo.componentone.com/ASPNET/ControlExplorer/explore/js/init.js

    This error also occurs in other machines here.
  • Replied 10 September 2017, 11:43 am EST

    Hi!

    These Demos are not working: http://demo.componentone.com/ASPNET/ControlExplorer/

    Thanks.
  • Replied 10 September 2017, 11:43 am EST

    Hello,

    I checked the link and it works fine at my end. I would request you to provide me more details like in which browser are you facing this issue along with its version and is it not working for any specific control or for all the controls ?

    Regards
    Ashish
  • Replied 10 September 2017, 11:43 am EST

    Hi, when mouse is over I can't see the submenus for example.

    Another! If I want to see the accordion control, the screen appears blank.

    The same goes for any other control.

    Error:
    --
    Detalhes dos erros da página da Web

    Agente de Usuário: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; InfoPath.2; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C; .NET4.0E)
    Carimbo de data/hora: Tue, 10 Jan 2012 14:26:09 UTC


    Mensagem: 'wijmo.wijtabs' é nulo ou não é um objeto
    Linha: 4
    Caractere: 2
    Código: 0
    URI: http://demo.componentone.com/ASPNET/ControlExplorer/WebResource.axd?d=s3qA1qvQGBPmkivS02AypjcgZvgoEQDtsqpDqIWXkblHD5TZfruNQtke5OH22nY2SGX8-nlTCeMypcL5ADPtoHHKr8_MErsQKtiaVV1xBJt0hIpxSe7Xh8Jkr4-ld7ED913EUNuXqbDwGQPsS-EwJBHXuhPoYehxCRr4uqytM3UrU2FP0&t=634570629280940000


    Mensagem: O objeto não dá suporte para a propriedade ou método
    Linha: 17
    Caractere: 2
    Código: 0
    URI: http://demo.componentone.com/ASPNET/ControlExplorer/explore/js/init.js
    --
  • Replied 10 September 2017, 11:43 am EST

    Hello,

    The issue is fixed in C1Wijmo build 3.5/4.0.20121.56 which is available at :
    http://prerelease.componentone.com/dotnet30/c1webwijmo.webforms/2012-t1/C1WebWijmo.Webforms_3.5.20121.56.zip

    Thanks,
    Richa
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels