Missing-Resource Error

Posted by: carverjc on 10 September 2017, 11:46 am EST

  • Posted 10 September 2017, 11:46 am EST

    My web app is using a C1Window (C1.Web.UI.Controls.4.dll, file version 4.0.20111.211) with VisualStyle = "Vista". Every time the window opens, it throws two exceptions that translate to "Missing resources: TitleTextLeft_unfocused.png and TitleTextRight_unfoced.png". In ~/C1VisualStyles/Vista/C1Window, there were .gif versions of those two files, but no .png versions. I opened the .gif versions, exported them as .png files, and included the .png files in my project. No joy -- still getting the missing-resource errors. Can anyone tell me what else I need to do to fix this? Obviously I could use a different visual style, but that's not really the point, is it? Also: Does it make sense that these exceptions are NOT raised when I'm running the app in Visual Studio? Is sure is hard to debug something when it happens only in the production environment!
  • Replied 10 September 2017, 11:46 am EST

    Hi,

    I could not reproduce the issue you've mentioned with C1Window. I see that you're using an older build.
    Could you try the latest build and see if the error still persists? You can download it from this url :
    http://prerelease.componentone.com/dotnet20/c1webui/2012-t1/C1WebUI.2_2.0.20121.228.zip

    If the still persists, please attach a sample which replicates the issue and with which browser are you getting this error, on which OS?

    Thanks
  • Replied 10 September 2017, 11:46 am EST

    Thanks, but the newer DLL didn't fix the problem. WebResource.axd is still complaining that these resources are missing:

    pC1.Web.UI.Controls.4|C1.Web.UI.Controls.C1Window.VisualStyles.Vista.Images.TitleTextLeft_unfocused.png

    pC1.Web.UI.Controls.4|C1.Web.UI.Controls.C1Window.VisualStyles.Vista.Images.TitleTextRight_unfocused.png

    I'm no expert on web resources, but my intuition tells me that the problem is that the two images in question exist as GIFs and the C1Window control is looking for PNGs.

    In any case, this isn't a show-stopper; trapping the exception thrown by WebResource.axd works fine.
  • Replied 10 September 2017, 11:46 am EST

    Hi,

    Good to know that you could get around the issue. However, if this is an issue, I would like to investigate further on it and get it fixed so that it longer causes any problem. Could you please share a small sample with me so that I can forward it to the concerned team.
    Please mention the OS and the browser with its version on which you're facing this issue and any other info that might be helpful in replicating the issue.

    Thanks
  • Replied 10 September 2017, 11:46 am EST

    The attached file contains a scanned image of the code in one of the .aspx files using C1Window with VisualStyle = “Vista” (sorry about the PDF, but I can't copy and paste because I work on a closed network).

    Workstation OS: Windows XP (SP 3)
    Server OS: Windows Server 3
    Browser: IE 8
    2012/05/Code.pdf
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels