Unable to change C1Inputs correctly

Originally Posted 4 December 2015, 12:01 am EST

  • Originally Posted 4 December 2015, 12:01 am EST

    Hello,

    1) I have several C1Inputs such as C1InputCurrency and C1InputDate and they are very big by default (height). However changing the height property does not work correctly, it does change the height of the control, however the text is cutted and does not get centered properly.
    I'm attaching a screenshot... I'd like to change the date size as well but the same thing occurs.

    2) I have a C1InputCurrency that is Enabled=False so it gets gray... Then I have a checkbox which calls a javascript that enables the C1InputCurrency, although it does enable it successfully (as I can edit and put values on it) it stays gray, visually speaking it does not change when the javascript changes the enabled state, therefore the user cannot notice that it is enabled.


    //element is the checkbox that is calling this function
    //inputValorMatricula is the C1InputCurrency that is Enabled=False in the asp page by default.
    function changeMatricula(element) {
    document.getElementById(('<%= inputValorMatricula.ClientID %>')).disabled = !element.checked;
    }


    Thanks in advance,
    Luís

  • Reply

    Hello, I have updated to latest version but I still have the same issue.
    1) I have discovered WHY it happens here, it is because my C1InputDate is inside a asp:table and it behaviers differently in there.
    If I only use the C1InputDate its height is fine. If I place it inside a table its height grows.. and if I set my table's CellSpacing to 10 then the C1InputDate grows even more, and it should not, as everything else behaviers just fine!

    Here is an example


    <form id="form1" runat="server">
    <wijmo:C1InputDate ID="C1InputDate3" runat="server"></wijmo:C1InputDate>




    <asp:Table runat="server">
    <asp:TableRow>
    <asp:TableCell>
    Teste:
    </asp:TableCell>
    <asp:TableCell>
    <wijmo:C1InputDate ID="C1InputDate2" runat="server"></wijmo:C1InputDate>
    </asp:TableCell>
    </asp:TableRow>
    </asp:Table>




    <asp:Table runat="server" CellSpacing="10">
    <asp:TableRow>
    <asp:TableCell>
    Teste:
    </asp:TableCell>
    <asp:TableCell>
    <wijmo:C1InputDate ID="C1InputDate1" runat="server"></wijmo:C1InputDate>
    </asp:TableCell>
    </asp:TableRow>
    </asp:Table>

    </form>

    Don't know how to workaround this... what can I do and why does it behaviers like that?

    2) This script regarding c1input did the trick.

    Thanks in advance,
    Luís Henrique.
  • Reply

    Regarding 2) The example did work, but it didn't work in my code because my checkbox is inside an updatepanel. The code you provided doesn't have any effect if my checkbox is inside the update panel, what can I do?

    I have attached the sample to reflect my reality.
    2016/01/MultipleC1Inputs-within-UpdatePanel.rar
  • Reply

    Hi,

    1. We could not replicate the issue at our end using the latest build of Studio for ASP.NET WebForms i.e. 4.0.20153.223

    Please refer to the attached sample application and an image depicting the behavior observed at our end.

    2. Please refer to the attached modified sample application in which we have resolved the mentioned issue.

    Hope it helps.

    Regards,
    Raunak Ladha

    2016/01/C1Input_HeightIssue_Image.zip

    2016/01/MultipleC1Inputs_Modified.zip

    2016/01/C1InputDate_HeightIssue.zip
  • Reply

    Hi, thanks for your response.

    1) Indeed, it works on IE/Edge, I have tested and noticed it has this issue/bug on Chrome only.
    I've attached a printscreen from both browsers.

    2) Your example did work, but if the checkbox is inside a C1Wizard as well it does not. (Attached project)


    2016/01/MultipleC1Inputs-Inside-C1Wizard-and-Update.rar
  • Marked as Answer

    Reply

    Hi,

    1. We could replicate the issue at our end as well. We have escalated the issue to the development team and will let you know as soon as we get any information from them.

    2. In order to resolve such issue, we would suggest you to set the ‘ClientIDMode’ property of both checkbox and C1InputCurrency to ‘Static’.

    Here is the code snippet:

    <wijmo:C1InputCurrency ID="C1InputCurrency1" runat="server" DecimalPlaces="0" Enabled="False" Culture="pt-BR" CurrencySymbol="$" ClientIDMode="Static">
    </wijmo:C1InputCurrency>
      
    <asp:CheckBox runat="server" ID="check" Checked="false" ClientIDMode="Static" />


    Please let us know if issue still persists.

    Regards,
    Raunak Ladha
  • Reply

    Hi,

    We would like to answer your queries in the order you have asked them:

    1. We are sorry to mention but we could not replicate the issue at our end using the latest build of Studio for ASP.NET WebForms i.e. 3.5.20153.222. Both C1InputCurrency and C1InputDate control are displayed with correct height in the web page.

    You can download the latest build by using the following link:
    http://prerelease.componentone.com/dotnet30/c1webwijmo.webforms/2015-t3/C1WebWijmo.Webforms_3.5.20153.222.zip

    Kindly check your sample application with latest build. If issue persists, then please modify the attached sample application replicating the issue so that we can look into it accordingly.

    2. You can enable or disabled the C1InputCurrency at run time by using the following code snippet:

    $("#check").change(function (e, args) {
    if (e.currentTarget.checked) {
    $('#C1InputCurrency1').c1inputcurrency("option", "disabled", false);
    }
    else {
    $('#C1InputCurrency1').c1inputcurrency("option", "disabled", true);
    }
    })


    For complete implementation, please refer to the attached sample application.

    Regards,
    Raunak Ladha

    2015/12/MultipleC1Inputs.zip
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels