Issue with filtering...

Posted by: sdixon on 3 August 2017, 7:00 am EST

  • Posted 3 August 2017, 7:00 am EST

    moved an attribute to the "Filters" box. A list of potential values is displayed. Clicked on "Clear" to remove all of the checks. Clicked on 3 of the values, and the OK. Received the following 2 errors:



    "Layout is out of date"



    and then



    "Action failed: Data", with the message "Exception: Data at the root level is invalid. Line 1, position 1."



    Any advice as to how to avoid this issue?
  • Replied 3 August 2017, 7:00 am EST

    1) We are using Version 2.1.766.0.



    2) I will see if I can put together a project to simulate this. As a side note, this issue seems to be related to the dataset being very large, and the field being filtered on containing many rows (very low level of granularity).
  • Replied 3 August 2017, 7:00 am EST

    sdixon,

    I have not be able to replicate this issue at my end ,could you please provide me the following details so that I can assist you further.

    1.Build of GrapeCity ActiveAnalysis that you are currently using.

    2. A sample application that would help us replciate the issue with the Cube that you are using.

    Best Regards,
    Abhishek
  • Replied 3 August 2017, 7:00 am EST

    Attachment
    2012/05/WebApplication1.zip
  • Replied 3 August 2017, 7:00 am EST

    sdixon,

    I was unable to find any attachment in your last post, could you please attach the sample application to your post.

    Best Regards,
    Abhishek
  • Replied 3 August 2017, 7:00 am EST

    To reproduce...



    OS: Windows 7 ultimate.



    Run this web application in IIS 7. AppPool should be .Net 4, Integrated mode, Enable 32 bit false.



    Drag "Fiscal Year" to the columns area, "Test Attribute2" to the rows area, and "Amount" the data area. Then drag "Test Attribute2" to the filters area. In the "Manual Filter" popup, click on "Clear", and then select any 3 items. Click on "OK". You should now see the errors.



    Thanks for your help...
  • Replied 3 August 2017, 7:00 am EST

    sdixon,

    I have still not being able to replicate after deploying a sample application at my end ,it would be best if you could send us a sample application so that I may look into it.

    Best Regards,
    Abhishek
  • Replied 3 August 2017, 7:00 am EST

    additional info...this issue happens in IIS 7.0 (.net 4.0), but not in the VS development server.
  • Replied 3 August 2017, 7:00 am EST

    sdixon,

    I was able to replicate the issue and I have entered a case with tracking number 162101 to have this issue fixed by our developmnet team. I have also added your email to the list of correspondents for this case and you will be notified as soon as the case gets resolved.

    Best Regards,
    Abhishek
  • Replied 3 August 2017, 7:00 am EST

    I am facing same issue with Active Analysis control version 2.1.827.0

    Please find the screenshot of the issue

    Is this issue resolved with latest update?

  • Replied 3 August 2017, 7:00 am EST

    Hello,

    I tested this issue with the latest interim build 942 and it works correctly at my end. Could you kindly check with the same and let me know your observations ?

    Here is the link : ftp://ftp.componentone.com/SUPPORTFTP/public/ActiveAnalysis/gcaa-2.1.942.0.zip

    Regards
  • Replied 3 August 2017, 7:00 am EST

    sdixon,

    <span id="BugEvents">Our developers have investigated case 162101 and came to conclusion that it's not a bug in ActiveAnalysis. ActiveAnalysis places the request data in
    HTTP headers and they have a limited size of 16
    KB. Hence, when the requested data exceeds this limited size the data gets truncated and hence it causes the problem.


    You will need to change the </span><span id="BugEvents">Http.sys registry settings for IIS </span>in order to resolve this.The steps to do the same are explained below.
    <span id="BugEvents">


    1. Locate registry key path "HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters".

    2. Add registry key "MaxRequestBytes" (DWORD 32-bit values) with decimal value "16777216" under this path.

    3. Add registry key "MaxFieldLength" (DWORD 32-bit values) with decimal value "65534" under this path.

    4. Restart your machine.

    You can find more information regarding Http.sys registry settings for IIS from here: http://support.microsoft.com/kb/820129</span>


    Best Regards,
    Abhishek
  • Replied 3 August 2017, 7:00 am EST

    sdixon,



    I would like you to know that making changes in the registry settings for the IIS will affect other web applications as well and hence it is not suggested to make use of the workaround that was provided earlier. I would also like you to know that our development team is working to resolve this within the scope of ActiveAnalysis so that making modifications to the registry settings of the IIS may be avoided . I will update you on the status of this case as I get further updates.

    Best Regards,
    Abhishek
  • Replied 3 August 2017, 7:00 am EST

    Thank you for the reply Abhishek. While this may not have been a bug in ActiveAnalysis, the error message that was being returned was not helpful...maybe this could be a feature request for the future?
  • Replied 3 August 2017, 7:00 am EST

    sdixon,

    I have already entered a documentation case regarding this error so that we can add the error and the corresponding solution to the Troubleshooting section of GrapeCity Analysis documentation , so that it could help developers troubleshoot this error.

    Best Regards,
    Abhishek
  • Replied 3 August 2017, 7:00 am EST

    Hello,

    It seems that there was some issue in uploading the file and hence, I am unable to download it. Could you kindly upload the same again so that I can check the issue ?

    Regards
  • Replied 3 August 2017, 7:00 am EST

    Hi Ashish

    Please find the database attached for your testing purpose.You will need Windows 2008 R2 to restore database
  • Replied 3 August 2017, 7:00 am EST

    Hello,

    Could you kindly share your database or provide a dummy database which could you help me in replicating the issue at my end ?

    Regards
    Ashish
  • Replied 3 August 2017, 7:00 am EST

    Hi Abhishek

    I tested this issue by updating Active Analysis control to build version 2.1.942.0 but still getting same issue

    Please find the screenshot of the issue

  • Replied 3 August 2017, 7:00 am EST

    As we are using windows identity foundation as authentication mechanism it’s create authentication cookie in HTTP header, we observe that when we run Adhoc report which is created using “GrapeCity.ActiveAnalysis.Web” it’s write data into HTTP header (e.g. Snap-Date data), result of that is HTTP header size increases and we got error as show in screen-shot (i.e. HTTP header is too long).

    Please find attached database and fiddler error detail screen-shot

    Hope this will help you to reproduce the issue, Please let us know if you need more details.
    2013/09/test_snap1.7z


  • Replied 3 August 2017, 7:00 am EST

    Uploading file once again
    2013/09/test_snap.7z
  • Replied 3 August 2017, 7:00 am EST

    Hello,

    As I said in earlier post, I am unable to download the database. Could you kindly upload it on your ftp site or you can upload it on www.speedyshare.com so that I can download it and can check the issue ?

    Regards
  • Replied 10 January 2018, 7:15 am EST

    Has this issue been fixed? I have a client that is experiencing the same issue.

    Thanks!
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels