Code Based Section Reports, .NET Framework 4.7.2, Designers Won't Load

Posted by: carl.bono on 10 April 2023, 6:25 am EST

  • Posted 10 April 2023, 6:25 am EST

    We have hundreds of code-based section reports in our reporting class library (some with quite a bit of code).

    Since upgrading to Active Reports 16 we are unable to load the designer for any reports that inherit from other reports (in our case most of them inherit from a MasterReport where we typically have our header and footer setup (with code behind as well). This was not a problem in v14 (we skipped 15).

    I’ve tried Visual Studio 2019 and Visual Studio 2022 with no luck.

    This is a MAJOR issue for us. I’ve seen similar threads on here about designers not loading, but they were all working with .NET Core, etc.

  • Posted 10 April 2023, 5:38 pm EST

    Hi Carl,

    Please refer to the following page of our documentation for breaking changes from ActiveReports 14 to ActiveReports 16. Breaking Changes

    I would suggest you to use the upgrade tool on your project. However, first please make sure you are using the latest version of ActiveReports 16 i.e. ActiveReports 16.4. For upgrading the project to ActiveReports 16.4, first download and install ActiveReports 16.4 using the following link: Download

    Now, Open the Project containing the reports in Visual Studio and unload all other projects. Close all report designer tabs and then go to Tools>Convert to ActiveReports 16. This will modify the reports’ designer.cs files and also re-add all the ActiveReports references using the version ActiveReports 16.4.

    If the issue persists, then please share some sample reports with their master reports reproducing the issue and also share the error message that appears when you open the report designer, so we can replicate the issue at our end and get back to you accordingly.



  • Posted 11 April 2023, 4:21 am EST

    Carl, I was having the same problem. My framework was 4.8, but their binaries only from the ./461 tools folder anyway. I was finding that it was throwing an exception at the target of invocation and wouldn’t load GrapeCity.Document.Imaging v6.0.3.0 (or any updated version).

    I had to repair the installation of Active Reports and that finally worked

    (Windows 11 => Add Remove Programs => Click on Hamburger Menu => Uninstall => Ok on Installer => Repair)

    Not sure why you have to tell Windows 11 to uninstall so that you can then repair, but this finally worked for me. Good luck!

  • Posted 11 April 2023, 9:22 pm EST

    Hi Nick,

    Thanks for sharing your solution with us. It will help others facing similar issues.

    Carl, let us know if the above suggestion provided by Nick resolves your issue. If not, then please share some sample reports with their master reports reproducing the issue and also share the error message that appears when you open the report designer, so we can replicate the issue at our end and get back to you accordingly.

  • Posted 12 April 2023, 6:06 am EST

    Thanks Nick, unfortunately, that didn’t solve the problem. I’m still having the same issue. However, I haven’t been able to reproduce yet with a super simple application example.

    One thing of note, many of these reports have been upgraded from version to version over several years. Perhaps there’s something with that.

  • Posted 13 April 2023, 3:40 pm EST

    Hi Carl,

    This could be an issue with the upgrade. Please share some sample reports so we can try to reproduce this issue at our end and get back to you accordingly. For each report you may share the following files:

    • report’s *.cs or *.vb file
    • reports designer file *.designer.cs or *.designer.vb
    • resource file .resx

    Also let us know what version of .Net Framework are you using and also share the project type and the error message you are receiving when opening the report into the Visual Studio integrated designer



  • Posted 19 April 2023, 2:22 am EST - Updated 19 April 2023, 2:30 am EST

    Attached is a zip file with 2 sections reports… Master and AgentInformation.

    AgentInformation derives from Master

    The error that I get is attached as an image.


  • Posted 19 April 2023, 11:44 am EST - Updated 19 April 2023, 11:49 am EST

    Here’s something I noticed when comparing project files between a brand new project and one that we’ve upgraded (probably many times). See attached picture.

    Note: Top is new, bottom is old/existing.

  • Posted 19 April 2023, 10:38 pm EST - Updated 19 April 2023, 10:43 pm EST

    Hi Carl,

    We created a new project using ActiveReports 16.4 and added your provided report samples, however, on our end we are able to open the report designer as expected.

    We have attached images/sample along with this response, we suspect this issue could be related to incompatible versions of packages being referenced in your project.

    To fix this issue, open your project in Visual Studio, close any open Designer window, and use the ‘Tools > Convert to ActiveReports 16’ option to convert all the ActiveReports packages in your project to their compatible version with respect to the version of ActiveReports installed on your system.

    Now rebuild your project and try opening your Code-Based SectionReport.

    However, if the issue persists, please try sharing a stripped-down sample (you can delete the bin, obj and packages folder) that replicates the issue so we could replicate the issue on our end and further investigate the same.



    P.S.: It is recommended to locally store the sample as the sample will get deleted from the drive in 5 days.

    Project Sample:

  • Posted 20 April 2023, 2:19 am EST

    I am unable to download the zip file, it is restricted.

  • Posted 20 April 2023, 9:43 pm EST

    Hi Carl,

    I have re-uploaded the file with public access. You may use the following link to download the file:

    Make sure to download the sample within the next 7 days as the link will expire after that.

  • Posted 27 April 2023, 4:00 am EST

    We are also having the same issue. We are using AR16.1.2

    When we run the tool “Convert to Active Reports 16”, it replaces our reference to AR16.1.2 with AR16.0.0 and set the target framework to 4.7.2. It does fix the designer issue and we are able to view the designer. However, we can’t run the reports within our program, since our main project is using 16.1.2 and on .NET Framework 4.8 and we can’t change them to AR16.0.0 and/or .NET Framework 4.72

    And when we try to install 16.1.2 after we ran the tool, the designer broke again.

    So, did it work in 16.0.0, broken in 16.2.1 and fixed in 16.4 again?

  • Posted 30 April 2023, 2:26 pm EST

    Hi Diah,

    It looks like you have got ActiveReports 16.0.0 installed on your system, therefore running the ‘Convert To ActiveReports 16’ tool is converting your ActiveReports references to v16.0.0 as this tool converts the packages to the version of ActiveReports installed on a system.

    Also, the issue with the target framework getting changed to v4.7.2 when using the ‘Converter Tool’ has been fixed in ActiveReports v16.2 and above.

    To fix your issue please download the latest version of ActiveReports 16 i.e. v16.4 from here And then open your project in VisualStudio to use the ‘Convert To ActiveReports 16’ tool.

    This should fix both of your issues! However, if the issue persists please try sharing a stripped down sample of your project so we could replicate the issue on our end and further investigate the same.



Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels