Unable to view report in Visual Studio 2017 Design. Method not found:

Posted by: tim_artz on 14 February 2020, 12:49 am EST

  • Posted 14 February 2020, 12:49 am EST

    I have upgraded our Visual Studio solution from ActiveReports 9 to ActiveReports 14. I am not getting any compile errors but when I try to view the reports in the report designer I get the error "Method not found: 'GrapeCity.ActiveReports.Drawing.TextAlignment GrapeCity.ActiveReports.Controls.Design.IRichEditDesignTarget.get_SelectionAlignment().

    The projects are using .NET Framework 4.6.2. I also downloaded the AR 14 hot fix (v14.0.19313) and the hot fix did not fix the issue.
  • Replied 16 February 2020, 11:19 pm EST

    Hello,

    We working on this. We will update once the new hotfix is released. If you provide us the sample then our QA team will test your scenario as well.

    Thanks,
    Mohit
  • Marked as Answer

    Replied 17 February 2020, 2:10 am EST

    I was able to fix the problem. I found the designer worked when I created a new project with a new report. Then I tested an existing report (that was upgraded from 9 to 14) and copied that report to the new project. I found i was able to view the report in the designer in the new project. This told me then the problem was not related to the report file itself but something with the Visual Studio project (2017). After comparing project file and references between the two projects I found that I was missing the GrapceCity.ActiveReports.Design.Win reference. Once I added that it worked. It appears to me that the ActiveReports 14 converter didn't add the missing reference.
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels