Filter Parameters with embedded JSON

Posted by: seaninglis on 23 September 2022, 7:24 am EST

  • Posted 23 September 2022, 7:24 am EST

    Hi, I have an embedded report designer where each datasource is set as an embedded datasource with “jsondata=” in the Connection.

    This is working fine, and I can dynamically set the static JSON for each datasource and use it in the report.

    However I’m struggling to get report parameters to work as a filter over the JSON data.

    I can define, for instance, a string parameter, and then use it in filter clause with a like - “.*” operator. However this input parameter is not presented when the report is run,

    If I state that the parameter can be empty / null, no parameters icon appears in the left menu on the report.

    If I change things so that the parameter cannot be empty / null, the parameters icon appears, but no prompt for the parameter or entry field is displayed, the space where this should be is blank.

    Do you have an example of a report with embedded JSON that uses a parameter value as a filter so I could check to see what I’ve missed?

    Sean

  • Posted 25 September 2022, 7:33 pm EST

    Hello, It sounds like the parameters panel is invisible. Please ensure that the height of the element that hosts the viewer instance is explicitly set in the CSS rules.

  • Posted 26 September 2022, 6:21 am EST

    Thanks, that was exactly the issue - back on track.

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels