Component 'vsflex8l.ocx' or one of its dependencies not correctly registered: a

Posted by: dwglass on 30 June 2021, 4:08 am EST

  • Posted 30 June 2021, 4:08 am EST

    I am trying to distribute a VB6 application that uses vsflex8l.ocx, I have copied the file to c:\Windows\SysWOW64 and run the the command line "regsvr32 vsflex8l.ocx" from c:\Windows\SysWOW64. There is no error in registering the DLL, but when I run my application I get the error
    "Component 'vsflex8l.ocx' or one of its dependencies not correctly registered: a file is missing or invalid"

    Is there anything else that needs to be installed? I am on a clean windows 10 machine (nothing other than office 365 installed). Is there a VC runtime that is needed?
  • Replied 30 June 2021, 4:09 am EST

    Sorry wrong image on the last
  • Replied 30 June 2021, 4:20 am EST

    I also tried C:\Windows\SysWOW64>c1regsvr.exe C:\Windows\SysWOW64\vsflexl.ocx and I get:

    OleInitialize succeded.
    LoadLibrary vsflex8l.ocx failed.
  • Replied 30 June 2021, 4:22 am EST

    Better image showing the file is there and the call to c1regsvr
  • Marked as Answer

    Replied 19 September 2021, 9:26 pm EST

    Hi,

    This issue usually occurs when the file or component is not properly registered on the machine. Since you are using a 64-bit machine, it is essential to register the corresponding files manually. Note that we ship both a 32bit and 64bit version of our ActiveX controls. I'm assuming you're using the 32bit controls in your application.
    With 64-bit versions of Windows, the 32bit controls are stored in the C:\Windows\SysWow64 folder, and the 64bit controls are stored in the C:\Windows\System32 folder. This is the reverse of what seems logical, but this is the way Microsoft has done it.
    I would suggest trying registering the 64-bit control manually on your machine using the instructions provided in the following blog article:
    http://our.componentone.com/2012/02/10/registration-of-64-bit-activex-controls/
    You can download the corresponding files from the link below.
    https://prerelease.componentone.com/allfiles

    Once done, recompile your application and deploy the control version from the C:\Windows\SysWow64 folder along with your application and see if that resolves the issue.

    Thanks,
    Prabhat Sharma.
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels