Japanese localization bug in TDBCombo control (the other TrueDB controls work)

Posted by: dweiler on 5 July 2022, 4:40 am EST

  • Posted 5 July 2022, 4:40 am EST

    I have been using the ActiveX controls for many years and have been very happy with them.

    About a year ago I upgraded to the latest service pack in order to resolve an issue with the TDBDate control not drawing correctly on a secondary monitor, and as far as I can tell there have been no newer service packs for the TrueDB controls.

    We have customers all over the world, and the controls are used in various localized environments (e.g. English, Arabic, Korean, Russian, etc.) I have recently discovered a localization error in the TDBCombo control and was wondering if anybody knows of a work around or if this is a bug inherent in the control that needs fixing.

    While I am going to describe the issue below using text, I have also attached a zipped .pdf which includes screen snapshots of each step.

    First let me explain how the other TrueDB controls are working correctly.

    Step 1: In the Windows 10 regional settings, select Japanese as the language for non-Unicode programs.

    Step 2: Install the standard Japanese keyboard.

    Step 3: Once the Japanese keyboard is selected you can toggle between entering standard Roman text, or entering Japanese text. Toggle it to enter Japanese text.

    Step 4: When you type roman letters (e.g. j a p a n) into any field in any program then Windows automatically displays a suggested list of related Japanese words to select from.

    Step 5: When you select a Japanese word from the list then it is automatically entered into the current control. This works correctly in most of the applicable TrueDB controls, e.g. TDBText and TDBGrid. It also works correctly in other standard Windows controls such as TextBox and DBCombo.

    Step 6: THE BUG: However, now try to do the same thing in a TDBCombo 8.0 (OLEDB) control.

    Step 7: When the same word is selected, it is garbled and mixed in with roman letters. Since this works fine in your other controls and also in the standard Windows DBCombo control (which I assume was used as the base for the TDBCombo), I am guessing that there is some code within the control that is dropping some bytes in the text that is being automatically entered.

    Please note that I spent a considerable amount of time experimenting with the various properties in the TDBCombo control to see if there was any particular setting that was enabling or disabling the correct functionality, but no matter which settings I toggled back and forth it always failed the exact same way.

    Any help would be greatly appreciated!


  • Replied 5 July 2022, 4:43 am EST

    Here is the zip file that includes screen snapshots of the each step from the previous post.TDBComboControlBugSteps.zip
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels